[linux-dvb] Any chance of help with v4l-dvb-experimental / Avermedia A16D please?

Richard (MQ) osl2008 at googlemail.com
Tue Feb 12 19:15:09 CET 2008


Mauro,

Many thanks for your efforts. I hope the following is useful.
Currently running on OpenSuSE 11.0 Alpha2, kernel 2.6.24-6

Mauro Carvalho Chehab wrote:
...
> If you're getting too much errors, it may mean that you're having some
> conflicts on your compilation.
> 
> There is a recent patch at the tree that changed the module dependencies.
> (before the patch, videodev were dependent on v4l2-common - now, the dependency
> is the reverse. Only after "make distclean", the building system will
> correctly deal with this change)
> 
> Please try to do force a cleanup, with this:
> make distclean
OK - no errors
> make
OK - no errors but a handful of warnings e.g. possibly uninitialised
variables in ov7670 module
> make rminstall
OK - no errors
> make rmmod
OK - no errors
> make install
OK - no errors
> modprobe saa7134 tuner=71
entire addition to /var/log/messages follows:
Feb 12 17:57:52 DevBox2400 klogd: Linux video capture interface: v2.00
Feb 12 17:57:52 DevBox2400 klogd: saa7130/34: v4l2 driver version 0.2.14
loaded
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: found at 0000:00:0d.0,
rev: 209, irq: 19, latency: 32, mmio: 0xe2000000
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: subsystem: 1461:f936,
board: AVerMedia Hybrid TV/Radio (A16D) [card=133,autodetected]
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: board init: gpio is 2fe00
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: i2c eeprom 00: 61 14 36 f9
00 00 00 00 00 00 00 00 00 00 00 00
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: i2c eeprom 10: ff ff ff ff
ff 20 ff ff ff ff ff ff ff ff ff ff
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: i2c eeprom 20: 01 40 01 02
02 01 01 00 08 ff 00 0e ff ff ff ff
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: i2c eeprom 30: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: i2c eeprom 40: ff 65 00 ff
c2 1e ff ff ff ff ff ff ff ff ff ff
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: i2c eeprom 50: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: i2c eeprom 60: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: i2c eeprom 70: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: i2c eeprom 80: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: i2c eeprom 90: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: i2c eeprom a0: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: i2c eeprom b0: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: i2c eeprom c0: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: i2c eeprom d0: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: i2c eeprom e0: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: i2c eeprom f0: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: registered device video0
[v4l2]
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: registered device vbi0
Feb 12 17:57:52 DevBox2400 klogd: saa7133[0]: registered device radio0

> please forward the errors that it might produce. You may forward the full dmesg
> errors to me in priv directly. I prefer if you don't generate a tarball, since
> makes easier for me to comment, the results, if needed.
OK, point taken. It's not huge...

In reply to your second message:

> I suspect that some gpio is needed before scanning tuners, in order to enable
> the i2c bus. Could you please do this:
> 
> 	modprobe saa7134 i2c_scan=1
> 
> and send me the complete dmesg after modprobing the board.

# rmmod saa7134
# modprobe saa7134 i2c_scan=1

Feb 12 18:03:26 DevBox2400 klogd: saa7130/34: v4l2 driver version 0.2.14
loaded
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: found at 0000:00:0d.0,
rev: 209, irq: 19, latency: 32, mmio: 0xe2000000
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: subsystem: 1461:f936,
board: AVerMedia Hybrid TV/Radio (A16D) [card=133,autodetected]
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: board init: gpio is 2fe00
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: i2c eeprom 00: 61 14 36 f9
00 00 00 00 00 00 00 00 00 00 00 00
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: i2c eeprom 10: ff ff ff ff
ff 20 ff ff ff ff ff ff ff ff ff ff
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: i2c eeprom 20: 01 40 01 02
02 01 01 00 08 ff 00 0e ff ff ff ff
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: i2c eeprom 30: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: i2c eeprom 40: ff 65 00 ff
c2 1e ff ff ff ff ff ff ff ff ff ff
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: i2c eeprom 50: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: i2c eeprom 60: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: i2c eeprom 70: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: i2c eeprom 80: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: i2c eeprom 90: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: i2c eeprom a0: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: i2c eeprom b0: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: i2c eeprom c0: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: i2c eeprom d0: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: i2c eeprom e0: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: i2c eeprom f0: ff ff ff ff
ff ff ff ff ff ff ff ff ff ff ff ff
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: i2c scan: found device @
0x1e  [???]
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: i2c scan: found device @
0xa0  [eeprom]
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: registered device video0
[v4l2]
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: registered device vbi0
Feb 12 18:03:26 DevBox2400 klogd: saa7133[0]: registered device radio0

During the above, /etc/modules.conf.local is empty. Added
> options tuner debug=1
> options tuner-xc2028 debug=1
and tried again, output is exactly the same except for the timestamps.

Thanks again for looking at this
Cheers
Richard (MQ)



More information about the linux-dvb mailing list