[linux-dvb] [PATCH] experimental support for C-1501 (fwd)

siestagomez at web.de siestagomez at web.de
Mon Jun 16 16:35:03 CEST 2008


Sigmund Augdal schrieb: 

> On Mon, 2008-06-16 at 08:14 +0300, Arthur Konovalov wrote:
>> SG wrote:
>> > The patch works quite well and nearly all channels seem to work.
>> > 
>> > But when tuning to some radio channels I'll get this kernel message:
>> > 
>> > saa7146 (0) saa7146_i2c_writeout [irq]: timed out waiting for end of xfer
>> > 
>> > Also I'm not able to tune to 'transponder 386000000 6900000 0 3' which works
>> > smoothly when using Win32.
>> > 
>> > initial transponder 386000000 6900000 0 3
>> >  >>> tune to: 386:M64:C:6900:
>> > WARNING: >>> tuning failed!!!
>> >  >>> tune to: 386:M64:C:6900: (tuning failed)
>> > WARNING: >>> tuning failed!!!
>> > ERROR: initial tuning failed
>> > dumping lists (0 services)
>> > Done.  
>> 
>> Yes, I discovered too that tuning to frequency 386MHz has no lock.
>> VDR channels.conf: TV3:386000:C0M64:C:6875:703:803:0:0:1003:16:1:0  
>> 
>> At same time, 394MHz (and others) works.
> Hi.  
> 
> Both transponders reported to not tune here has different symbolrates
> from what I used for my testing. Maybe this is relevant in some way.
> Could you please compare this with the channels that did tune to see if
> there is a pattern?  
> 
> About the i2c message, I get that every now and then here as well, but I
> have not seen any ill effect from it. I also see that on some other TT
> cards so I think that might be unrelated to the demod/tuner.  
> 
> Regards  
> 
> Sigmund Augdal

The symbolrate is the same on all other working channels. 

Regarding the i2c message when watching video I'll get this only once but 
when tuning to a radio channel my log gets flooded and it seems to hangup. 

Martin 





More information about the linux-dvb mailing list