[linux-dvb] pctv452e and TT-S2-3600 step-by-step howto

Michael Schöller michael.schoeller at schoeller-soft.net
Thu Jun 19 21:59:06 CEST 2008


Maybe this is an hint that will enable you to find the problem. I just 
looked at the dmesg messages right after I tried ./simpledvbtune -f 
11954 and well this are the messages:

pctv452e_power_ctrl: 1
ioctl32(simpledvbtune:5591): Unknown cmd fd(3) cmd(80046f57){t:'o';sz:4} 
arg(ff8c43e8) on /dev/dvb/adapter0/frontend0
lnbp22_set_voltage: 1 (18V=1 13V=0)
lnbp22_set_voltage: 0x72)
ioctl32(simpledvbtune:5591): Unknown cmd fd(3) 
cmd(80ac6f53){t:'o';sz:172} arg(ff8c433c) on /dev/dvb/adapter0/frontend0
lnbp22_set_voltage: 2 (18V=1 13V=0)
lnbp22_set_voltage: 0x60)
pctv452e_power_ctrl: 0

Maybe that helps..
Oh I almost forgot. The leds on the Receiver. After loading the kernel 
modules they go from orange to green. After trying simpledvbtune they go 
from green to orange and never back.

Michael

Dominik Kuhlen schrieb:
> On Sunday 08 June 2008, Michael Schöller wrote:
>   
>> Dominik Kuhlen schrieb:
>>     
>>> Hi,
>>>
>>> I have attached a step-by-step howto for these devices
>>>
>>>
>>> Happy testing,
>>>  Dominik
>>>
>>>   
>>> ------------------------------------------------------------------------
>>>
>>> _______________________________________________
>>> linux-dvb mailing list
>>> linux-dvb at linuxtv.org
>>> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb
>>>       
>> Well bad news...it's not working.
>> I try to notice any difference in my system to your description and well 
>> it's not much...
>> My dmesg line:
>>
>> stb0899_get_dev_id: Device ID=[3], Release=[1]
>>
>> Your dmesg line:
>>
>> stb0899_get_dev_id: Device ID=[3], Release=[0]
>>
>> all other dmesg messages are identical.
>>
>>  next difference
>>
>> ls -l /dev/dvb/adapter0/
>> # total 0
>> # crw------- 1 schomi root 212, 4 Jun  7 15:37 demux0
>> # crw------- 1 schomi root 212, 5 Jun  7 15:37 dvr0
>> # crw------- 1 schomi root 212, 3 Jun  7 15:37 frontend0
>> # crw------- 1 schomi root 212, 7 Jun  7 15:37 net0
>>
>> well just do be sure I also tried chmod a+rw * but that didn't change anything. Well since schomi is my user I think that should be ok...
>>
>> So now to the real problem...
>> ./simpledvbtune -f 11954
>> using '/dev/dvb/adapter0/frontend0' as frontend
>> frontend fd=3: type=0
>> DVBFE_SET_DELSYS: Invalid argument
>> ioclt: FE_SET_VOLTAGE : 1
>> High band
>> tone: 1
>> dvbfe setparams :  delsys=1 1354MHz / Rate : 27500kBPS
>> DVBFE_SET_PARAMS: Invalid argument
>> tuning qpsk failed
>>     
> Hmm, this is strange. looks like you are using old drivers or old dvb-core module that doesn't support the new ioctls
> Did you load the modules with
> insmod ./dvb-core.ko
> insmod ./dvb-usb.ko
> insmod ./lnbp22.ko
> insmod ./stb0899.ko
> insmod ./stb6100.ko
> insmod ./dvb-usb-pctv452e.ko
> to be sure that no old/other modules were used?
>
>   
>> @Dominik
>> By any chance do you live in austria and can visit me ^^.
>>     
> No, sorry I don't.
>   
>> Michael
>>
>>
>>
>>     
>
> Dominik
>
>   
> ------------------------------------------------------------------------
>
> _______________________________________________
> linux-dvb mailing list
> linux-dvb at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/linux-dvb/attachments/20080619/34da5e8d/attachment.htm 


More information about the linux-dvb mailing list