[linux-dvb] Getting Avermedia AverTV E506 DVB-T to work - SOLVED

Lukas.Orlowski at dlr.de Lukas.Orlowski at dlr.de
Tue Jun 24 09:17:31 CEST 2008


 

> >
> > I am struggling to enjoy DVB-T on my AverTV E506
> PCMCIA card. It seams
> > I'm doing something terribly wrong but I cannot
> find the solution on my
> > own. I am grateful for any help provided.

which program are you using for TV (I'm using kplayer that runs mplayer)

> >
> > What I did so far:
> >
> > I'm running Gentoo with a 2.6.24-r8 kernel on my
> Centrino Laptop. I have
> > selected "Video for Linux" (nothing else, no
> cards, no frontends, no
> > chips..) as a module in my kernel configuration and
> compiled the
> > "v4l-dvb" drivers from the mercurial
> repository. I also have obtained
> > the (hopefully) correct firmware for my card.
> >
> > Well when I plug the PCMCIA device in this is what
> dmesg shows me:

This one seems to be OK.

> > xc2028 5-0061: creating new instance
> > xc2028 5-0061: type set to XCeive xc2028/xc3028 tuner
> > xc2028 5-0061: Loading 80 firmware images from
> xc3028-v27.fw, type:
> > xc2028 firmware, ver 2.7
> > xc2028 5-0061: Loading firmware for type=BASE F8MHZ
> (3), id
> > 0000000000000000.
> > (0), id 00000000000000ff:
> > xc2028 5-0061: Loading firmware for type=(0), id
> 0000000100000007.
> > SCODE (20000000), id 0000000100000007:
> > xc2028 5-0061: Loading SCODE for type=MONO SCODE
> HAS_IF_5320 (60008000),
> > id 0000000800000007.
> > saa7133[0]: registered device video0 [v4l2]
> > saa7133[0]: registered device vbi0
> > saa7133[0]: registered device radio0
> >
> > Analog TV works with this setup, but I have no signs
> of DVB-T. No
> > /dev/dvb devices are created although the module for

>Your DVB device is vbi0

>/dev/vbi0

>see the last lines from your dmsg

>I've tried vlc too it works also very well. You just have to point your

>tv app to read from vbi0

>I think this is your problem

>regards

>---------------------------------------
>
>Hi 
>
>With respect, I think the /dev/vbi0 device is responsible for teletext
(videotext).
>I require the whole /dev/dvb/adapter0/ structure to use dvbscan for
channel scanning.
>Currently I'm dissecting the driver source code, adding debug messages
to certain section (pretty lame, I know but I'm out of options).
>
>As far as I can tell "mt352_attach" gets called. I'm working on finding
the weak spot.
>
>regards
>
>Luke

---------------------------------------

Stranger things have happened, it works. I removed all old modules from
/lib/modules/2.6.24-r8/v4l-dvb and media, compiled the
v4l-dvb-experimental package and now I my frontend works. Devices are
getting created and although DVB-T reception is quit4e crappy in my area
I watched my first few minutes of digital TV last night.

Thanks everyone.

Regards

Luke



More information about the linux-dvb mailing list