[linux-dvb] hvr-1300 analog audio question

Simon Farnsworth simon.farnsworth at onelan.co.uk
Mon Jun 30 12:11:20 CEST 2008


Please don't drop the cc when replying - I'm passing on my own 
experiences with an unrelated card, in the hope that it helps you.

Someone else on the list may look at this and have an "aha!" moment, 
answering your question for you.

Note that the increased buffering is important for the SAA7134 - it 
seems to only be prepared to transfer audio data in blanking time, so if 
there's not enough buffering available, it just drops samples.

yoshi watanabe wrote:
> i tried 32000 before when using arecord | aplay combo but the arecord
> insisted on 48000 audio rate. will try again and report later, thanks.
> 
> On Mon, Jun 30, 2008 at 11:24 AM, Simon Farnsworth
> <simon.farnsworth at onelan.co.uk> wrote:
>> yoshi watanabe wrote:
>>> hello.
>>>
>>> i'm using hauppauge hvr-1300 to receive video signal from playstation2
>>> console, pal model. video is just fine, but i'm having strange audio
>>> issues, but judging by some searching i did - that's pretty common
>>> with this card , although people have varied experience with the card.
>>>
>> I've had similar issues with SAA7134 based cards, which were resolved by
>>  changing audio parameters.
>>
>> If your problem is the same as mine was, try:
>> arecord --format=S16 \
>>        --rate=32000 \
>>        --period-size=8192 \
>>        --buffer-size=524288 | aplay
>>
>> This forces 32kHz sampling, and gives the card lots of buffer space to play
>> with.
>> --
>> Simon Farnsworth
>>
>>
> 
> 
> 


-- 
Simon Farnsworth
Software Engineer

ONELAN Limited
1st Floor Andersen House
Newtown Road
Henley-on-Thames, OXON
RG9 1HG
United Kingdom

Tel:    +44(0)1491 411400
Fax:    +44(0)1491 579254
Support:+44(0)1491 845282

www.onelan.co.uk




More information about the linux-dvb mailing list