[linux-dvb] Oops in tda10023

Sigmund Augdal sigmund at snap.tv
Fri May 30 11:15:09 CEST 2008


tor, 29.05.2008 kl. 20.52 +0300, skrev Antti Palosaari:
> Sigmund Augdal wrote:
> > using latest hg v4l-dvb on a 2.6.20 kernel.
> 
> I did some changes recently to tda10023 (needed for Anysee driver). I 
> wonder if these errors start coming after that? Those changes are 
> committed to master only few days ago, 05/26/2008.
When the crash happened I was using a module with these changes
included. This doesn't necessarily mean that these changes were the
cause of the problem. From reading the relevant diff I'd say it's quite
unlikely that your changes is causing the problem, as tda10023_writereg
was called from tda10023_attach before also, and you didn't change
anything in tda10023_writereg it self. I also know for a fact that the
i2c problems also did happen without your changes, so your changes isn't
the cause of that either.

About your changes to the tda10023 module, I tried these a while ago
(before they were merged into master, with a technotrend C-1501 board
that has a tda10023 demod with at tda8274a silicon tuner. I figured the
tuner had the same deltaf setting as the tuner used in anysee (based on
how this tuner is used in conjunction with tda10046), but I couldn't
figure out values for the pll_x parameters. I tried setting them to the
the same as the ones used in the anysee tree , but I couldn't get any
lock still, it may however be because my signal was bad at that point.
If I remember correctly your comments said something about an unknown
tuner used in the anysee device. Is there any chance it actually is the
tda827x? As this tuner-demod combo is sold as a refference design from
phillips.

Best Regards

Sigmund
> 
> regards
> Antti




More information about the linux-dvb mailing list