[linux-dvb] FIXME: audio doesn't work on svideo/composite - hvr-1110 S-Video and Composite

tomlohave at gmail.com tomlohave at gmail.com
Mon Sep 22 13:03:50 CEST 2008


David Bentham a écrit :
>   
>>>>>         
>>>>>           
>>>> there are different models of the HVR-1110 we can see on
>>>> hauppauge_eeprom down in saa7134-cards.c.
>>>>
>>>> Some don't even have analog audio in.
>>>>
>>>> In case it is there, if the current LINE2 stereo input pair doesn't
>>>> work, then it is LINE1.
>>>>
>>>>         
>
>   
>> By default the driver will set it to 0, only for that input gpio =
>> 0x0200000 is set in the card's config, it will change it to 1.
>> (masked writes, "modinfo saa7134" gpio_tracking=1)
>>
>> If changing the amux to LINE1 doesn't help for s-video and composite,
>> testing with saa7134-alsa there and say sox, then regspy might help.
>>
>> If you use the supplied m$ app, not DScaler, and save the logs for the
>> card in status unused, TV, composite/s-video and radio, we will see the
>> gpio mask in use there and likely changing gpio pins.
>>
>> They often have more pins in the mask and also more that change,
>> but usually one of them will be what we need to add to the mask.
>>
>> It looks like manufacturers group their devices together with a gpio
>> mask covering so far all of them, then subsets of devices do appear,
>> which still do more changes on the pins, then for a specific single
>> device would be needed.
>>
>> With a high granularity for each device, based on a doubtless and
>> consistent eeprom detection, the gpio settings likely could be single
>> device specific too, if wanted.
>>
>> But since we might see unrelated gpio changes there too, dunno, first of
>> all make sure that amux LINE1 does not resolve the problem.
>>
>> Cheers,
>> Hermann
>>
>>
>>
>>
>>
>>   
>> I remember that regspy shows nothing when i attempted to switch to 
>> svideo/composite.
>> i haven't got a pc with windows (only linux + freevo on it) so i can't 
>> do anything else for now.
>>     
>
>   
>> Line1 doesn't work for me so it's why there is a FIXME in sources ....
>>     
>
>   
>> Cheers,
>>     
>
>   
>> Thomas.
>>     
>
> Hopefully running regspy will tell me more. Can I send the dump logs here?,
> hopefully you can give me some key pointers?
>
> I'll Try several actions to see what if anything, will arise from it.
>   
You can try here :
http://sourceforge.net/project/downloading.php?groupname=deinterlace&filename=DScaler4115.exe&use_mirror=heanet

regspy is included in DScaler

Post your log here

Cheers,
Thomas



More information about the linux-dvb mailing list