Cool.<br>
<br>
Just in the process of upgrading FC4 with the 2.6.13 kernel to work
with the latest CVS tree, so I'll let you (all) know how it goes.<br>
<br>
James.<br><br><div><span class="gmail_quote">On 10/25/05, <b class="gmail_sendername">Simo Kivimäki</b> &lt;<a href="mailto:simo.j.kivimaki@tut.fi">simo.j.kivimaki@tut.fi</a>&gt; wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
James Fisher wrote:<br>&gt; I've just got hold of one of these as a replacement for my previous<br>&gt; DVB-C card which is no longer available.<br>&gt;<br>&gt; Are the drivers for this board checked into CVS?<br><br>There is driver for TT DVB-C 1500 but it has problmes with QAM128
<br>signal. I have tried to increase timeouts and still tuning gets locked<br>only occasionally with my card. The kernel modules are budget-ci and<br>stv0297. I don't have access to non-QAM128 signals so I don't know how<br>
they work.<br><br>It would be nice to get that card working so what is the situation with<br>the driver development?<br><br>I recently made some testing with stv0297_cs2 driver and used it with my<br>DVB-C 1500 card. With some changes it compiled as the driver for DVB-C
<br>1500 card and the budget-ci registers the frontend correctly.<br><br>But it does not work. Of course that's not a surprise because the driver<br>is not made for the card.<br><br>Here's dmesg debug messages for the cs2 driver used with TT:
<br>spectrum inversion: off<br>symbolrate: 6900000, regval: 0000000000000000<br>initialized - waiting for the locks now<br>waiting for WBAGC lock<br>WBAGC has lock<br>waiting for equalizer 1 lock<br>timed out<br><br>And that repeats.
<br><br>Changes that I made to get it 'work':<br>- Change the name to stv0297 (files and api functions)<br>- Added 'u8 invert:1' and 'u8* inittab' to struct stv0297_config in<br>header file.<br>- In function stv0297_readregsI changed the i2c_transfer to be done in
<br>to parts.<br><br>I'm not familiar with the kernel drivers nor stv0297 so I have no idea<br>for further modifications. I hope that some developer could try to solve<br>this problem in some way or give advice for me to debug it.
<br></blockquote></div><br>