I just tried testing the new HG branch of v4l-dvb with linux kernl 2.6.16-rc5 and have come across a few minor issues. <br>
<br>
1)&nbsp; If I have any dvb modules built in the kernel before building
v4l-dvb outside the tree, the symbols seem to conflict when trying to
load the HG modules.&nbsp; Fix: Disable all DVB modules in kernel
before building dvb modules outside the tree.<br>
<br>
saa7146_vv: disagrees about version of symbol video_unregister_device<br>
saa7146_vv: Unknown symbol video_unregister_device<br>
saa7146_vv: disagrees about version of symbol video_device_alloc<br>
saa7146_vv: Unknown symbol video_device_alloc<br>
saa7146_vv: disagrees about version of symbol video_register_device<br>
saa7146_vv: Unknown symbol video_register_device<br>
saa7146_vv: disagrees about version of symbol video_device_release<br>
saa7146_vv: Unknown symbol video_device_release<br>
dvb_ttpci: Unknown symbol saa7146_vv_init<br>
dvb_ttpci: Unknown symbol saa7146_vv_release<br>
dvb_ttpci: Unknown symbol saa7146_start_preview<br>
dvb_ttpci: Unknown symbol saa7146_unregister_device<br>
dvb_ttpci: Unknown symbol saa7146_register_device<br>
dvb_ttpci: Unknown symbol saa7146_set_hps_source_and_sync<br>
dvb_ttpci: Unknown symbol saa7146_stop_preview<br>
<br>
<br>
2) After doing &quot;make install&quot;, there is no videodev.ko in
/lib/mod/{kernel}/kernel/drivers/media/video/videodev.ko.&nbsp;
Something is wrong with the Makefile where it is not installing
videodev.ko.&nbsp; If videodev.ko does not exist, I get the following
error:<br>
<br>
saa7146_vv: Unknown symbol video_unregister_device<br>
saa7146_vv: Unknown symbol video_device_alloc<br>
saa7146_vv: Unknown symbol video_register_device<br>
saa7146_vv: Unknown symbol video_usercopy<br>
saa7146_vv: Unknown symbol video_device_release<br>
<br>
<br>
Thanks,<br>