<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 TRANSITIONAL//EN">
<HTML>
<HEAD>
  <META HTTP-EQUIV="Content-Type" CONTENT="text/html; CHARSET=UTF-8">
  <META NAME="GENERATOR" CONTENT="GtkHTML/3.2.5">
</HEAD>
<BODY>
Thanks for your reply.<BR>
<BR>
I noticed there is a zl10353 module which the cx88_dvb module uses. So does this mean that the cx88-dvb module should be recognising my card?<BR>
<BR>
Maybe the manufacturer has changed the demodulator on the Lite card? <BR>
<BR>
Incidentally a friend of mine has brought the same card (well the packaging is the same) but it has the <FONT COLOR="#000000">Zarlink MT352 DVB-T demodulato</FONT>r on it and it all works.<BR>
<BR>
On Thu, 2006-04-06 at 19:14 +0200, Markus Rechberger wrote: 
<BLOCKQUOTE TYPE=CITE>
<PRE>
<FONT COLOR="#000000">Hi,</FONT>

<FONT COLOR="#000000">0x14 is the returnvalue of a Zarlink/Intel ZL10353 based device not a</FONT>
<FONT COLOR="#000000">Zarlink MT352 DVB-T demodulator.</FONT>

<FONT COLOR="#000000">Markus</FONT>

<FONT COLOR="#000000">On 4/6/06, Martin Petrovsky &lt;<A HREF="mailto:mpetrovsky@swiftdsl.com.au">mpetrovsky@swiftdsl.com.au</A>&gt; wrote:</FONT>
<FONT COLOR="#000000">&gt;  Hello Chris,</FONT>
<FONT COLOR="#000000">&gt;</FONT>
<FONT COLOR="#000000">&gt;  I've just brought a DViCO FusionHDTV DVB-T Lite card (lspci attached) and</FONT>
<FONT COLOR="#000000">&gt; I'm having a few problems getting it to work. I was hoping on some advice.</FONT>
<FONT COLOR="#000000">&gt;</FONT>
<FONT COLOR="#000000">&gt;  I don't have much experience with dvb under linux, so I apologise for any</FONT>
<FONT COLOR="#000000">&gt; ignorance.</FONT>
<FONT COLOR="#000000">&gt;</FONT>
<FONT COLOR="#000000">&gt;  I'm using kernel 2.6.16 with your hg-pascoe tree on top. I'm loading the</FONT>
<FONT COLOR="#000000">&gt; following modules</FONT>
<FONT COLOR="#000000">&gt;</FONT>
<FONT COLOR="#000000">&gt;  modprobe bttv</FONT>
<FONT COLOR="#000000">&gt;  modprobe mt352 debug=1</FONT>
<FONT COLOR="#000000">&gt;  modprobe cx88-dvb debug=8</FONT>
<FONT COLOR="#000000">&gt;  modprobe dst verbose=8</FONT>
<FONT COLOR="#000000">&gt;  modprobe dvb_bt8xx debug=8</FONT>
<FONT COLOR="#000000">&gt;</FONT>
<FONT COLOR="#000000">&gt;  I'm getting the following log</FONT>
<FONT COLOR="#000000">&gt;</FONT>
<FONT COLOR="#000000">&gt;  &lt;3&gt;i2c_core: Unknown parameter `debug'</FONT>
<FONT COLOR="#000000">&gt;  &lt;6&gt;Linux video capture interface: v1.00</FONT>
<FONT COLOR="#000000">&gt;  &lt;7&gt;i2c-core: driver [tveeprom] registered</FONT>
<FONT COLOR="#000000">&gt;  &lt;6&gt;bttv: driver version 0.9.16 loaded</FONT>
<FONT COLOR="#000000">&gt;  &lt;6&gt;bttv: using 8 buffers with 2080k (520 pages) each for capture</FONT>
<FONT COLOR="#000000">&gt;  &lt;6&gt;bttv: Bt8xx card found (0).</FONT>
<FONT COLOR="#000000">&gt;  &lt;6&gt;bttv0: Bt878 (rev 17) at 0000:03:08.0, irq: 10, latency: 32, mmio:</FONT>
<FONT COLOR="#000000">&gt; 0xfdcff000</FONT>
<FONT COLOR="#000000">&gt;  &lt;6&gt;bttv0: detected: DViCO FusionHDTV DVB-T Lite [card=128], PCI subsystem</FONT>
<FONT COLOR="#000000">&gt; ID is 18ac:db10</FONT>
<FONT COLOR="#000000">&gt;  &lt;6&gt;bttv0: using: DViCO FusionHDTV DVB-T Lite [card=128,autodetected]</FONT>
<FONT COLOR="#000000">&gt;  &lt;7&gt;bttv0: gpio: en=00000000, out=00000000 in=00ffffff [init]</FONT>
<FONT COLOR="#000000">&gt;  &lt;7&gt;i2c_adapter i2c-0: adapter [bt878 #0 [sw]] registered</FONT>
<FONT COLOR="#000000">&gt;  &lt;7&gt;i2c_adapter i2c-0: found normal entry for adapter 0, addr 0x50</FONT>
<FONT COLOR="#000000">&gt;  &lt;7&gt;i2c_adapter i2c-0: master_xfer[0] W, addr=0x50, len=0</FONT>
<FONT COLOR="#000000">&gt;  &lt;7&gt;i2c_adapter i2c-0: master_xfer[0] W, addr=0x50, len=0</FONT>
<FONT COLOR="#000000">&gt;  &lt;7&gt;i2c_adapter i2c-0: client [tveeprom] registered with bus id 0-0050</FONT>
<FONT COLOR="#000000">&gt;  &lt;4&gt;bttv0: using tuner=-1</FONT>
<FONT COLOR="#000000">&gt;  &lt;4&gt;bttv0: add subdevice &quot;dvb0&quot;</FONT>
<FONT COLOR="#000000">&gt;  &lt;6&gt;cx2388x dvb driver version 0.0.5 loaded</FONT>
<FONT COLOR="#000000">&gt;  &lt;6&gt;bt878: AUDIO driver version 0.0.0 loaded</FONT>
<FONT COLOR="#000000">&gt;  &lt;6&gt;bt878: Bt878 AUDIO function found (0).</FONT>
<FONT COLOR="#000000">&gt;  &lt;4&gt;bt878_probe: card id=[0xdb1018ac],[ DViCO FusionHDTV DVB-T Lite ] has</FONT>
<FONT COLOR="#000000">&gt; DVB functions.</FONT>
<FONT COLOR="#000000">&gt;  &lt;6&gt;bt878(0): Bt878 (rev 17) at 03:08.1, irq: 10, latency: 32, memory:</FONT>
<FONT COLOR="#000000">&gt; 0xfdcfe000</FONT>
<FONT COLOR="#000000">&gt;  &lt;7&gt;dvb_bt8xx: identified card0 as bttv0</FONT>
<FONT COLOR="#000000">&gt;  &lt;4&gt;DVB: registering new adapter (bttv0).</FONT>
<FONT COLOR="#000000">&gt;  &lt;7&gt;mt352: mt352_attach: hello</FONT>
<FONT COLOR="#000000">&gt;  &lt;7&gt;i2c_adapter i2c-0: master_xfer[0] W, addr=0x0f, len=1</FONT>
<FONT COLOR="#000000">&gt;  &lt;7&gt;i2c_adapter i2c-0: master_xfer[1] R, addr=0x0f, len=1</FONT>
<FONT COLOR="#000000">&gt;  &lt;7&gt;i2c_adapter i2c-0: master_xfer[0] W, addr=0x0f, len=1</FONT>
<FONT COLOR="#000000">&gt;  &lt;7&gt;i2c_adapter i2c-0: master_xfer[1] R, addr=0x0f, len=1</FONT>
<FONT COLOR="#000000">&gt;  &lt;7&gt;mt352: MJP -- mt352_read_register error. Exiting - 0014</FONT>
<FONT COLOR="#000000">&gt;  &lt;4&gt;dvb-bt8xx: A frontend driver was not found for device 109e/0878</FONT>
<FONT COLOR="#000000">&gt; subsystem 18ac/db10 type 0080</FONT>
<FONT COLOR="#000000">&gt;</FONT>
<FONT COLOR="#000000">&gt;  It looks like it's bailing out at mt352_attach . The call to</FONT>
<FONT COLOR="#000000">&gt; mt352_read_register seams to be returning 0x14 not the expected ID_MT352</FONT>
<FONT COLOR="#000000">&gt; (0x13).</FONT>
<FONT COLOR="#000000">&gt;  Does this mean that the card I got has a different front end or something?</FONT>
<FONT COLOR="#000000">&gt;</FONT>
<FONT COLOR="#000000">&gt;  // mt352.c   mt352_read_register  line 550</FONT>
<FONT COLOR="#000000">&gt;          /* setup the state */</FONT>
<FONT COLOR="#000000">&gt;          state-&gt;i2c = i2c;</FONT>
<FONT COLOR="#000000">&gt;          memcpy(&amp;state-&gt;config,config,sizeof(struct</FONT>
<FONT COLOR="#000000">&gt; mt352_config));</FONT>
<FONT COLOR="#000000">&gt;          memcpy(&amp;state-&gt;ops, &amp;mt352_ops, sizeof(struct dvb_frontend_ops));</FONT>
<FONT COLOR="#000000">&gt;</FONT>
<FONT COLOR="#000000">&gt;          /* check if the demod is there */</FONT>
<FONT COLOR="#000000">&gt;          if (mt352_read_register(state, CHIP_ID) != ID_MT352) {</FONT>
<FONT COLOR="#000000">&gt;                  dprintk(&quot;MJP -- mt352_read_register error. Exiting -</FONT>
<FONT COLOR="#000000">&gt; %04x\n&quot;, mt352_read_register(state, CHIP_ID));</FONT>
<FONT COLOR="#000000">&gt;                  goto error;</FONT>
<FONT COLOR="#000000">&gt;          }</FONT>
<FONT COLOR="#000000">&gt;</FONT>
<FONT COLOR="#000000">&gt;  I also noticed a &quot;bttv0: using tuner=-1&quot; message above. Is this related?</FONT>
<FONT COLOR="#000000">&gt;</FONT>
<FONT COLOR="#000000">&gt;  Any help would be appreciated,</FONT>
<FONT COLOR="#000000">&gt;</FONT>
<FONT COLOR="#000000">&gt;  Thanks</FONT>
<FONT COLOR="#000000">&gt;</FONT>
<FONT COLOR="#000000">&gt;  Martin P</FONT>
<FONT COLOR="#000000">&gt; _______________________________________________</FONT>
<FONT COLOR="#000000">&gt; linux-dvb mailing list</FONT>
<FONT COLOR="#000000">&gt; <A HREF="mailto:linux-dvb@linuxtv.org">linux-dvb@linuxtv.org</A></FONT>
<FONT COLOR="#000000">&gt; <A HREF="http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb">http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb</A></FONT>
<FONT COLOR="#000000">&gt;</FONT>
<FONT COLOR="#000000">&gt;</FONT>
<FONT COLOR="#000000">&gt;</FONT>


<FONT COLOR="#000000">--</FONT>
<FONT COLOR="#000000">Markus Rechberger</FONT>

<FONT COLOR="#000000">_______________________________________________</FONT>
<FONT COLOR="#000000">linux-dvb mailing list</FONT>
<FONT COLOR="#000000"><A HREF="mailto:linux-dvb@linuxtv.org">linux-dvb@linuxtv.org</A></FONT>
<FONT COLOR="#000000"><A HREF="http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb">http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb</A></FONT>

</PRE>
</BLOCKQUOTE>
<TABLE CELLSPACING="0" CELLPADDING="0" WIDTH="100%">
<TR>
<TD>
-- <BR>
Martin Petrovsky &lt;<A HREF="mailto:mpetrovsky@swiftdsl.com.au">mpetrovsky@swiftdsl.com.au</A>&gt;
</TD>
</TR>
</TABLE>
</BODY>
</HTML>