<div>I am also having this problem. How do I &quot;change the checks around xmit_lock from 2.6.18 to 2.6.17&quot; ?</div>
<div>&nbsp;</div>
<div>thanks in advance.<br><br>&nbsp;</div>
<div><span class="gmail_quote">On 09/08/06, <b class="gmail_sendername">Trent Piepho</b> &lt;<a href="mailto:xyzzy@speakeasy.org">xyzzy@speakeasy.org</a>&gt; wrote:</span>
<blockquote class="gmail_quote" style="PADDING-LEFT: 1ex; MARGIN: 0px 0px 0px 0.8ex; BORDER-LEFT: #ccc 1px solid">On Tue, 8 Aug 2006, dave wrote:<br>&gt; struct net_device<br>&gt;<br>&gt; xmit_lock is missing<br>&gt;<br>
&gt; May I be englightened as to the whereabouts of the definition of 'net_device'<br>&gt;<br>&gt; my search for it has drawn a blank using FEDORA 5 2.6.17 - 1.2157_FC5<br><br>It is defined in linux/netdevice.h<br><br>Your problem is that FC calls their kernel 
2.6.17, but it includes stuff<br>from 2.6.18.&nbsp;&nbsp;You should change the checks around xmit_lock from 2,6,18 to<br>2,6,17 for your kernel.<br><br>_______________________________________________<br>linux-dvb mailing list<br><a href="mailto:linux-dvb@linuxtv.org">
linux-dvb@linuxtv.org</a><br><a href="http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb">http://www.linuxtv.org/cgi-bin/mailman/listinfo/linux-dvb</a><br></blockquote></div><br>