Hmmm... The firmware not found problem clearly suggest that the partition containing the file it it's not mounted when the card is initialized. ┐Are you sure that those modules are really compiled as modules and not included embedded into the kernel?
<br><br>The firmware files are usually contained in /lib/firmware (at least, in my Sabayon/Gentoo box). ┐Maybe in yours the firmware are on any partition that for any unknown reason is mounted later? Check dmesg to see if the card is initialized before disks are mounted.
<br><br>Cheers<br>&nbsp; Eduard<br><br><br><br><br><br><div><span class="gmail_quote">2007/1/31, Jeffrey Borg &lt;<a href="mailto:jeffrey@borgs.net">jeffrey@borgs.net</a>&gt;:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<br>This is thi initial load<br><br>Jan 30 20:47:29 tux2 dib0700: loaded with support for 2 different<br>device-types<br>Jan 30 20:47:29 tux2 dvb-usb: found a &#39;Hauppauge Nova-T 500 Dual DVB-T&#39; in<br>cold state, will try to load a firmware
<br>Jan 30 20:47:29 tux2 dvb-usb: did not find the firmware file.<br>(dvb-usb-dib0700-01.fw) Please see linux/Documentation/dvb/ for more<br>details on firmware-problems.<br>(-2)<br><br><br>a liile while later (I did the modprobe manually)
<br>Jan 30 20:49:39 tux2 usbcore: deregistering interface driver<br>dvb_usb_dib0700<br>Jan 30 20:49:44 tux2 dib0700: loaded with support for 2 different<br>device-types<br>Jan 30 20:49:45 tux2 dvb-usb: found a &#39;Hauppauge Nova-T 500 Dual DVB-T&#39; in
<br>cold state, will try to load a firmware<br>Jan 30 20:49:45 tux2 dvb-usb: downloading firmware from file<br>&#39;dvb-usb-dib0700-01.fw&#39;<br>Jan 30 20:49:45 tux2 dib0700: firmware started successfully.<br>Jan 30 20:49:45 tux2 dvb-usb: found a &#39;Hauppauge Nova-T 500 Dual DVB-T&#39; in
<br>warm state.<br>Jan 30 20:49:45 tux2 **WARNING** I2C adapter driver [Hauppauge Nova-T 500<br>Dual DVB-T] forgot to specify physical device; fix it!<br>Jan 30 20:49:45 tux2 dvb-usb: will pass the complete MPEG2 transport
<br>stream to the software demuxer.<br>Jan 30 20:49:45 tux2 DVB: registering new adapter (Hauppauge Nova-T 500<br>Dual DVB-T).<br>Jan 30 20:49:45 tux2 **WARNING** I2C adapter driver [DiBX000 tuner I2C<br>bus] forgot to specify physical device; fix it!
<br>Jan 30 20:49:45 tux2 DVB: registering frontend 1 (DiBcom 3000MC/P)...<br>Jan 30 20:49:45 tux2 MT2060: successfully identified (IF1 = 1220)<br>Jan 30 20:49:46 tux2 dvb-usb: will pass the complete MPEG2 transport<br>stream to the software demuxer.
<br>Jan 30 20:49:46 tux2 DVB: registering new adapter (Hauppauge Nova-T 500<br>Dual DVB-T).<br>Jan 30 20:49:46 tux2 **WARNING** I2C adapter driver [DiBX000 tuner I2C<br>bus] forgot to specify physical device; fix it!<br>Jan 30 20:49:46 tux2 DVB: registering frontend 2 (DiBcom 3000MC/P)...
<br>Jan 30 20:49:46 tux2 MT2060: successfully identified (IF1 = 1220)<br>Jan 30 20:49:46 tux2 dvb-usb: Hauppauge Nova-T 500 Dual DVB-T successfully<br>initialized and connected.<br>Jan 30 20:49:46 tux2 usbcore: registered new interface driver
<br>dvb_usb_dib0700<br><br><br>I am still not 100% sure why the frimware is found on the 2nd loading.<br><br>Jeffrey<br><br><br>On Wed, 31 Jan 2007, Eduard Huguet wrote:<br><br>&gt; Ok, then I have no idea why you get this error first time. Try to post your
<br>&gt; dmesg file, maybe it can help.<br>&gt;<br>&gt; Cheers<br>&gt; Eduard<br>&gt;<br>&gt;<br>&gt;<br>&gt;<br>&gt; 2007/1/31, Jeffrey Borg &lt;<a href="mailto:jeffrey@borgs.net">jeffrey@borgs.net</a>&gt;:<br>&gt;&gt;<br>
&gt;&gt; Hi<br>&gt;&gt;<br>&gt;&gt; Everything is a module for the dvb stuff, even the other card needs<br>&gt;&gt; firmware. Just that this one dosen&#39;t initalize the first time.<br>&gt;&gt;<br>&gt;&gt; Jeffrey<br>&gt;&gt;
<br>&gt;&gt; On Wed, 31 Jan 2007, Eduard Huguet wrote:<br>&gt;&gt;<br>&gt;&gt; &gt; Hi,<br>&gt;&gt; &gt;&nbsp;&nbsp; ┐Do you compile the driver for the card as a module? Make sure you do,<br>&gt;&gt; &gt; because that card needs the firmware to be loaded, and if the driver is
<br>&gt;&gt; &gt; compiled inside the kernel (not as a module) then it initializes too<br>&gt;&gt; early<br>&gt;&gt; &gt; (before file systems are mounted) and it won&#39;t find the firmware file.<br>&gt;&gt; &gt;<br>&gt;&gt; &gt; Cheers
<br>&gt;&gt; &gt;<br>&gt;&gt;<br>&gt;<br></blockquote></div><br>