<div><span class="gmail_quote"></span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">It looks like the I2C gate on the demod is closed, and the tuning code
<br>is unable to reprogram the tuner. I don&#39;t know why off hand, I&#39;ve never<br>used radio personally.<br><br>It also looks like the demod is also not responding to i2c read requests.<br><br>After this error occurs, does DVB-T and/or analog tv work correctly? Ie.
<br>Does the problem clear itself.</blockquote><div><br>No, I first checked that I was able to see DVB-T, and that worked without problems. Then I&#39;ve started gnomeradio, and the errors were back into the dmesg. I&#39;ve tried to restart the TV, but this gives now also :
<br>[ 7744.066068] cx22702_readreg: readreg error (ret == -121)<br>[ 7744.066416] cx22702_writereg: writereg error (reg == 0x0b, val == 0x00, ret == -121)<br>[ 7744.066765] cx22702_readreg: readreg error (ret == -121)<br>
[ 7744.067116] cx22702_writereg: writereg error (reg == 0x0c, val == 0x40, ret == -121)<br><br>However, I see only error messages for cx22702. Next I tried to unload the cx22702 module and to reload it. To remove it I also had to remove cx88_dvb. The modprobe failed however:
<br><br>[ 7957.052276] cx8802_unregister_driver() -&gt;unregistering driver type=dvb<br>[ 7957.052283] CORE cx88[0]: subsystem: 0070:9600, board: Hauppauge WinTV-HVR1300 DVB-T/Hybrid MPEG Encoder [card=56]<br>Unload<br><br>
Tried to launch gnome-radio:<br>[ 8008.391208] tda9887 2-0043: i2c i/o error: rc == -121 (should be 4)<br>[ 8008.391647] tuner 2-0061: i2c i/o error: rc == -121 (should be 4)<br>[ 8008.395280] tda9887 2-0043: i2c i/o error: rc == -121 (should be 4)
<br>[ 8008.395700] tda9887 2-0043: i2c i/o error: rc == -121 (should be 4)<br>[ 8008.396122] tuner 2-0061: i2c i/o error: rc == -121 (should be 4)<br>[ 8008.399158] tda9887 2-0043: i2c i/o error: rc == -121 (should be 4)<br>
[ 8008.399585] tda9887 2-0043: i2c i/o error: rc == -121 (should be 4)<br>[ 8008.400005] tuner 2-0061: i2c i/o error: rc == -121 (should be 4)<br>[ 8011.129912] tda9887 2-0043: i2c i/o error: rc == -121 (should be 4)<br>modprobe cx88_dvb:
<br>[ 8038.842489] cx2388x dvb driver version 0.0.6 loaded<br>[ 8038.842496] cx8802_register_driver() -&gt;registering driver type=dvb access=shared<br>[ 8038.842501] CORE cx88[0]: subsystem: 0070:9600, board: Hauppauge WinTV-HVR1300 DVB-T/Hybrid MPEG Encoder [card=56]
<br>[ 8038.842783] cx88[0]/2: cx2388x based dvb card<br>[ 8038.855169] cx22702_readreg: readreg error (ret == -121)<br>[ 8038.855196] cx88[0]: frontend initialization failed<br>[ 8038.855199] cx8802_dvb_probe dvb_register failed err = -1
<br>[ 8038.855201] cx8802_register_driver() -&gt;probe failed err = -1<br><br><br>modprobe failed with: FATAL: Error inserting cx88_dvb (/lib/modules/2.6.20-11-generic/kernel/drivers/media/video/cx88/cx88-dvb.ko): No such device
<br><br></div><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">Could be a GPIO issue which I could look into. Let me know the the<br>answer to the above question.
</blockquote><div><br>I&#39;m running AMD64 on Ubuntu (both edgy and Feist) and have Gentoo available if needed.<br>Let me know what info you need ...<br><br>Manfred <br></div><br></div><br><br clear="all"><br>-- <br>--- 
<br>Manfred Haelters