I can&#39;t test it right now (I&#39;m out for work). But I&#39;ve looked the changes and they seem great for me, I just compiled and installed, without any problem, there&#39;s just the test left, for next weekend.<br><br>
Thanks!<br><br>Albert<br><br><div class="gmail_quote">2008/5/27 Mauro Carvalho Chehab &lt;<a href="mailto:mchehab@infradead.org">mchehab@infradead.org</a>&gt;:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
Hi Albert,<br>
<div class="Ih2E3d"><br>
On Tue, 27 May 2008 17:23:50 +0200<br>
&quot;Albert Comerma&quot; &lt;<a href="mailto:albert.comerma@gmail.com">albert.comerma@gmail.com</a>&gt; wrote:<br>
<br>
&gt; There seems to be a problem with the last changes on xc2028 code, please try<br>
&gt; this;<br>
&gt;<br>
&gt; In linux/drivers/media/common/tuners/tuner-xc2028.c file, on xc2028_attach,<br>
&gt; video_dev must be = cfg-&gt;video_dev;<br>
&gt; and on the current source it&#39;s = cfg-&gt;i2c_adap-&gt;algo_data; which completely<br>
&gt; breaks the module when loaded.<br>
&gt;<br>
&gt; It was already suggested that this should be changed, but nobody said why<br>
&gt; this modification was done or why it was kept.<br>
&gt;<br>
&gt; Mauro could you trace when and why this modification was done? or at least<br>
&gt; give it back to original state?<br>
&gt;<br>
<br>
</div>It seems that I forgot to merge the fix for this. I&#39;ve just committed it. Could<br>
you please test ? It is already available at mercurial tree.<br>
<br>
Cheers,<br>
<font color="#888888">Mauro<br>
</font></blockquote></div><br>