Hi<br><br>I have a Pinnacle PCTV Hybrid Pro310i card which I use on a MythBuntu 8.10 installation with a 2.6.27-11 Kernel. The installation works great out of the box except for one thing.<br><br>It often happens that I can&#39;t use the dvb part of the card. When this happens i get this from dmesg:<br>
<br>Feb 19 06:56:51 mythtv kernel: [  828.597021] tda1004x: setting up plls for 48MHz sampling clock<br>Feb 19 06:56:53 mythtv kernel: [  830.841022] tda1004x: timeout waiting for DSP ready<br>Feb 19 06:56:53 mythtv kernel: [  830.880022] tda1004x: found firmware revision 0 -- invalid<br>
Feb 19 06:56:53 mythtv kernel: [  830.880026] tda1004x: trying to boot from eeprom<br>Feb 19 06:56:56 mythtv kernel: [  833.209021] tda1004x: timeout waiting for DSP ready<br>Feb 19 06:56:56 mythtv kernel: [  833.248022] tda1004x: found firmware revision 0 -- invalid<br>
Feb 19 06:56:56 mythtv kernel: [  833.248025] tda1004x: waiting for firmware upload...<br>Feb 19 06:56:56 mythtv kernel: [  833.248029] firmware: requesting dvb-fe-tda10046.fw<br>Feb 19 06:57:10 mythtv kernel: [  847.772029] tda1004x: timeout waiting for DSP ready<br>
Feb 19 06:57:10 mythtv kernel: [  847.812019] tda1004x: found firmware revision 0 -- invalid<br>Feb 19 06:57:10 mythtv kernel: [  847.812024] tda1004x: firmware upload failed<br>Feb 19 06:57:42 mythtv kernel: [  879.832020] tda1004x: setting up plls for 48MHz sampling clock<br>
Feb 19 06:57:45 mythtv kernel: [  882.076020] tda1004x: timeout waiting for DSP ready<br>Feb 19 06:57:45 mythtv kernel: [  882.116016] tda1004x: found firmware revision 0 -- invalid<br>Feb 19 06:57:45 mythtv kernel: [  882.116021] tda1004x: trying to boot from eeprom<br>
Feb 19 06:57:47 mythtv kernel: [  884.444022] tda1004x: timeout waiting for DSP ready<br>Feb 19 06:57:47 mythtv kernel: [  884.484019] tda1004x: found firmware revision 0 -- invalid<br>Feb 19 06:57:47 mythtv kernel: [  884.484024] tda1004x: waiting for firmware upload...<br>
Feb 19 06:57:47 mythtv kernel: [  884.484027] firmware: requesting dvb-fe-tda10046.fw<br>Feb 19 06:58:02 mythtv kernel: [  899.164015] tda1004x: timeout waiting for DSP ready<br>Feb 19 06:58:02 mythtv kernel: [  899.204168] tda1004x: found firmware revision 0 -- invalid<br>
Feb 19 06:58:02 mythtv kernel: [  899.204175] tda1004x: firmware upload failed<br>Feb 19 07:14:31 mythtv kernel: [ 1888.392018] tda1004x: setting up plls for 48MHz sampling clock<br>Feb 19 07:14:33 mythtv kernel: [ 1890.636018] tda1004x: timeout waiting for DSP ready<br>
Feb 19 07:14:33 mythtv kernel: [ 1890.676016] tda1004x: found firmware revision 0 -- invalid<br>Feb 19 07:14:33 mythtv kernel: [ 1890.676020] tda1004x: trying to boot from eeprom<br>Feb 19 07:14:36 mythtv kernel: [ 1893.005014] tda1004x: timeout waiting for DSP ready<br>
Feb 19 07:14:36 mythtv kernel: [ 1893.045014] tda1004x: found firmware revision 0 -- invalid<br>Feb 19 07:14:36 mythtv kernel: [ 1893.045017] tda1004x: waiting for firmware upload...<br>Feb 19 07:14:36 mythtv kernel: [ 1893.045021] firmware: requesting dvb-fe-tda10046.fw<br>
Feb 19 07:14:50 mythtv kernel: [ 1907.516019] tda1004x: timeout waiting for DSP ready<br>Feb 19 07:14:50 mythtv kernel: [ 1907.556021] tda1004x: found firmware revision 0 -- invalid<br>Feb 19 07:14:50 mythtv kernel: [ 1907.556029] tda1004x: firmware upload failed<br>
<br><br>It does however not happen every time. I can&#39;t make out a clear pattern for when this occurs. When i diff the output from dmesg from when everything works with the output when i fails I can&#39;t find any significant difference. I hope someone recognizes this problem and can help me.<br>
<br><br>Best regards<br><br>/Fredrik<br>