[mpeg2] Status of the MPEX drivers?

Luca Abeni labeni at mbigroup.it
Tue Feb 15 18:14:44 CET 2005


Hi Andrew,

thanks for the reply.

On Tue, 2005-02-15 at 16:27, Andrew de Quincey wrote:
[...]
> > I notice that something changed in the /dev/video1 device, because the
> > program that I used to set the audio and video PIDs and bitrates
> > fails... Is the ioctl() interface changed?
> 
> yeah - it is now using an experimental v4l extension ioctl... have a look at 
> VIDIOC_G_MPEGCOMP in videodev.h.
Ah, ok... Thanks for the pointer; I'll look at it. Do you know about any
programs that already use such interface?

> > Also, I tried to capture some audio and video using the default
> > parameters, but the audio is captured at a very low volume...
> > Is this a known problem? I never encountered it before...
> 
> maybe the mixer settings? If you enable OSS support, you get a proper OSS 
> audio device that lets you switch inputs.
Ok... I enabled OSS support, and I loaded the saa7134 module with
"oss=1". However, aumix does not like the resulting mixer (it does not
permit to set the volume, but only to choose the input between "Line1"
or "Line2"). The volume is still low... I'll try a different input (I am
using a microphone right now).

			Thanks,
				Luca
-- 
_____________________________________________________________________________
Copy this in your signature, if you think it is important:
                               N O    W A R ! ! !
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 232 bytes
Desc: This is a digitally signed message part
Url : http://www.linuxtv.org/pipermail/mpeg2/attachments/20050215/a5328936/attachment.pgp


More information about the mpeg2 mailing list