[vdr] Remote plugin breakage with 2.6.15-rc1+ kernel

Oliver Endriss o.endriss at gmx.de
Sun Nov 13 16:48:53 CET 2005


C.Y.M wrote:
> C.Y.M wrote:
> > As of 2.6.15-rc1 (actually the change was originally made in 2.6.14-git8), there
> > is no more /dev/input/event0 node.  The nodes now start at event1 and up.  This
> > breaks the autodetect feature in the remote plugin for VDR.  I was able to
> > kludge a fix by hacking the default to the event I am currently using, but a
> > real fix should be made instead.
> > 
> > This is *hacked* fix for a remote that is using event3.  This only a kludge.
> 
> OK, this seems like a much better fix for 2.6.15-rc1+ kernels and the remote
> plugin.  Now autodetect works again for the events.
> ...

No, that's not the way to go.
It would break the remote plugin for kernel 2.4.

<flame>
The way kernel 2.6.x is being developed is a pain in the a**. :§$%
They are changing interfaces at will, and it is virtually impossible to
write drivers for the 2.6 series...
</flame>

I will not look into this before 2.6.15 is out.
For now you should specify the interface with the '-i' option.

Oliver

-- 
--------------------------------------------------------
VDR Remote Plugin available at
http://www.escape-edv.de/endriss/vdr/
--------------------------------------------------------



More information about the vdr mailing list