[vdr] Re: Softdevice plugin problem

Norm Dressler norm at dressler.ca
Wed Nov 16 02:51:01 CET 2005


>>
> hmm.. Interesting.  I installed ffmpeg as a Debian package.  I think I 
> have the source around here somewhere.  I'll try a recompile on the 
> source and see that helps.  Thanks!
>
> Norm

Trying to recompile ffmpeg from the package source and running into a 
problem -- I don't know enough about ffmpeg to diagnose this one..
gcc -fPIC -DPIC -O3 -Wall -Wno-switch  -DHAVE_AV_CONFIG_H -I.. 
-I'/usr/src/ffmpeg-0.cvs20050918'/libavutil -D_FILE_OFFSET_BITS=64 
-D_LARGEFILE_SOURCE -D_GNU_SOURCE   -mmmx  -c -o i386/dsputil_mmx.o 
i386/dsputil_mmx.c
i386/dsputil_mmx.c: In function `transpose4x4':
i386/dsputil_mmx.c:630: error: incompatible type for argument 1 of 
`__builtin_ia32_punpckhwd'
i386/dsputil_mmx.c:630: error: incompatible type for argument 2 of 
`__builtin_ia32_punpckhwd'
i386/dsputil_mmx.c:630: error: incompatible types in assignment

Any suggestions?

Thx
Norm



More information about the vdr mailing list