[vdr] xine plugin sync problems on analog channels

Cristiano c.bozzi at meta.cpr.it
Thu Nov 17 18:12:29 CET 2005


Hi all,

I am having some problem with vdr xine and analogtv plugin.

I have a client-server vdr installation based on vdr 1.3.34, xine 0.7.6 
plugin, when I select a DVB channel I have no problems but if I select 
an analog channel (stream generated by analogtv plugin 0.9.37 with ivtv 
0.4.0 and PVR 150 card) I had some sync problem: here is the xine log:

audio jump, diff=-51840
audio_out: inserting 27627 0-frames to fill a gap of 51815 pts
video jump
bad_frame
video jump
video jump
bad_frame
video_out: throwing away image with pts 653020 because it's too old 
(diff : 6489
9).
200 frames delivered, 14 frames skipped, 1 frames discarded
video_out: throwing away image with pts 2753839 because it's too old 
(diff : 418
6).
bad_frame
bad_frame
video jump
bad_frame
bad_frame
audio jump, diff=-51850
audio_out: inserting 27655 0-frames to fill a gap of 51866 pts
video jump
bad_frame
video jump
bad_frame
bad_frame
200 frames delivered, 7 frames skipped, 1 frames discarded
video_out: throwing away image with pts 5052089 because it's too old 
(diff : 4544).
200 frames delivered, 0 frames skipped, 1 frames discarded
bad_frame
audio jump, diff=-45370
audio_out: inserting 24197 0-frames to fill a gap of 45382 pts
video jump
video jump
video jump
bad_frame
video_out: throwing away image with pts 6157260 because it's too old 
(diff : 54139).

Searching on the vdr mailing list I found a thread ("problem 
vdr-xine-0.7.3 plugin") that seems to be related to this issue.
I tried to "play" with WRAP_THRESHOLD values without good results

Did you have any suggestion?

Thanks in advance for your help
Cristiano



More information about the vdr mailing list