[vdr] vdr and analogtv and xine?

Torsten Mohr tmohr at s.netic.de
Sun Oct 9 08:57:49 CEST 2005


Hi,

i'd like to record movies with my Hauppauge PVR 350 and use
my normal graphics card to view movies.

So i configured and installed the plugins analogtv and xine.

In one shell i start "vdr -Panalogtv -Pxine" and in another
shell:
xine "vdr:/tmp/vdr-xine/stream#demux:mpeg_pes"

I can see the OSD in xine, but only the background "No Signal".

I can record from /dev/video via command line, so basically it
should work.  Also, i can configure the keyboard keys for VDR
and can use them to control VDR, i can see that with the OSD
in xine.

In vdr i get the output attached below.  I wonder about the
line that says that says:

/dev/video0 ('WinTV PVR 350') does not support streaming i/o.

Whenever i press a key in VDR, i get an output line by "xine"
that says:

vdr: osdflush: n: 1, 10, 4  # the numbers are varying.


So does VDR not update the screen of xine cyclically?


How can i get a picture in xine?  Do i need another plugin?
Or some other options?


Best regards,
Torsten.

08:38:48 analogTV version 0.9.37 starting up ...
08:38:48
08:38:48 Copyright (C) 2003 .. 2005 by Andreas Kool (akool at gmx.de)
08:38:48
08:38:48 The analogTV plugin is the work of many people;
08:38:48 for at least a partial list see CREDITS.
08:38:48
08:38:48 analogTV comes with ABSOLUTELY NO WARRANTY; for details see COPYING.
08:38:48 This is free software, and you are welcome to redistribute it
08:38:48 under certain conditions; see COPYING for details.
08:38:48
08:38:48 Detected Linux version 2.6.12-default
08:38:48 Detected VDR version 1.3.33
08:38:48 Detected plain-vanilla VDR (hopefully :-)
08:38:48 cSchedules created
SetVideoFormat: 0
08:38:48 Detected ConfigDirectory()="/video/plugins"
08:38:48 CPU AMD Duron(TM), family 6, model 8, stepping 1
08:38:48 CPU measured at 1350.040MHz
08:38:48 Using SSE optimized memcpy()
vdr-xine: Client connecting ...
vdr-xine: Client connected!
08:38:58 Switching to channel 0 on device 5
08:38:58 Switching to channel 0 on device 4
08:38:58 Channel: S 25, SID=12003, 335.25 MHz (S25), PAL
08:38:58 Video device: /dev/video0
08:38:58 Video source: 4:
08:38:58 NEW videodev=/dev/video0
08:38:58 Detected V4L version 2
08:38:58 Detected capture device Vanilla iTVC15 card
08:38:58 Detected hardware Hauppauge PVR
08:38:58 This device have a tuner
08:38:58 This device is able for capturing
08:38:58 This device have a onboard MPEG-Encoder
08:38:58 Detected Input#0: Composite 0
08:38:58 Detected Input#1: Composite 1
08:38:58 Detected Input#2: Composite 2
08:38:58 Detected Input#3: Composite 3
08:38:58 Detected Input#4: Tuner 0
08:38:58 Detected Input#5: Composite 4
08:38:58 Detected Input#6: S-Video 0
08:38:58 Detected Input#7: S-Video 1
08:38:58 Detected Input#8: S-Video 2
08:38:58 Detected Input#9: S-Video 3
08:38:58 NEW Frequency=335250 + 0
08:38:58 NEW videonorm=PAL
08:38:58 NEW videosource=4:Tuner 0
08:38:58 NEW picture properties
08:38:58 setPictureProperties(fd=9) failed, 34:Numerical result out of range
08:38:58 Could not set (all) picture properties
08:38:58 tune(5364) [frequency=335250, freqOffset=16, ofs=0]
08:38:58 setNorm(0:PAL (0xff))
08:38:58 Switching to channel 1 on device 4
SetAudioChannelDevice: 0
08:38:58 Switching to channel 1 on device 5
SetVolumeDevice: 255
SetPlayMode: 1
08:38:58 NEW Audio-PID=300, Video-PID=301
08:38:58 runEncoder(Apid=300, Vpid=301)
08:38:58 mp1e -m 3 -j -e 1 -t 256 -g I -p /dev/dsp -c /dev/video0 
-x /dev/mixer -d 4 -a 3 -b 5000000 -B 80 -r 14,91 -s 480x576 -S 44.1 -F 8 -G 
496x576 -o /tmp/.analogtv.avi &
08:38:58 Sucessfully set encoder priority to -15
08:38:58 flush_buffer()
mp1e:v4l25.c:216: /dev/video0 ('WinTV PVR 350') does not support streaming 
i/o.
read(4) returned 0, error 0: Success
vdr-xine: Client disconnected!
SetPlayMode: 0




More information about the vdr mailing list