[vdr] capabilites not supported in linux 2.4

Alfred Zastrow vdr at zastrow4u.de
Mon Apr 17 16:45:24 CEST 2006


Christoph Gohle schrieb:

> vdr can not be compiled on my 2.4 system because setting capabilities is 
> not supported.
> 
> Maybe it would be nice if this feature is automatically disabled if a 
> 2.4 kernel is found? This would save compatability to older systems.
> 
> Only a suggestion.

 From the readme of libcap-1.10:

Overview 

-------- 

 

As of Linux 2.2.0, the power of the superuser has been partitioned 

into a set of discrete capabilities (in other places, these 

capabilities are know as privileges). 

 

The contents of the libcap package are a library and a number of
[...]


It should not be a problem to install this lib on a 2.4.x-kernel.


regards
Alfred




More information about the vdr mailing list