[vdr] [ANNOUNCE] VDR developer version 1.3.48

Stefan Huelswitt s.huelswitt at gmx.de
Sun Apr 23 17:09:19 CEST 2006


On 23 Apr 2006 Klaus Schmidinger <Klaus.Schmidinger at cadsoft.de> wrote:

> - Added an error message about plugins that don't honor APIVERSION in their Makefile
>    (based on a suggestion by Udo Richter).

There is a small bug:

#make plugins
/bin/sh: line 1: @noapiv=: command not found
Plugin mp3:
make[1]: Entering directory `/usr/local/source/VDR/vdr-1.3.48/PLUGINS/src/mp3-unstable'
[...]

Fix:

--- Makefile.orig       2006-04-23 17:04:21.000000000 +0200
+++ Makefile    2006-04-23 17:06:07.000000000 +0200
@@ -176,7 +176,7 @@
 
 plugins: include-dir
        @failed="";\
-       @noapiv="";\
+       noapiv="";\
        for i in `ls $(PLUGINDIR)/src | grep -v '[^a-z0-9]'`; do\
            echo "Plugin $$i:";\
            if ! grep -q "\$$(LIBDIR)/.*\$$(APIVERSION)" "$(PLUGINDIR)/src/$$i/Makefile" ; then\

Regards.

-- 
Stefan Huelswitt
s.huelswitt at gmx.de  | http://www.muempf.de/



More information about the vdr mailing list