[vdr] [ANNOUNCE] VDR developer version 1.3.48

Jörg Wendel vdr-ml at jwendel.de
Tue Apr 25 00:06:08 CEST 2006


Hi again,

ok, sorry it is to late ;)
I have applied the patch and tested again with the old version of grep and it 
works fine! 
The line with the expression isn't changed by the patch, but it works now. May 
be i can find the trick tomorrow ;)

Jörg


On Montag 24 April 2006 23:50, Jörg Wendel wrote:
> On Montag 24 April 2006 22:36, Klaus Schmidinger wrote:
> > Jörg Wendel wrote:
> > > Hi,
> > >
> > > just a little hint. The regular expression in the VDR Makefile which
> > > detects if the APIVERSION is used in the plugins Makefile is not
> > > compatible with the grep version of linvdr 07 (grep version 2.4.2).
> > > Since i have updated grep to version 2.5.1 all works fine.
> >
> > A solution for this has already been posted earlier on this list.
> > Please take a look at the 'vdr-1.3.48-apiversion.diff' I've posted,
> > or the original posting by Oliver Endriss.
>
> I have seen this patch, but the problem with the old version of grep is the
> following line of the VDR makefile:
>
> if ! grep -q "\$$(LIBDIR)/.*\$$(APIVERSION)"
> "$(PLUGINDIR)/src/$$i/Makefile" ; then\
>
> and in the 'vdr-1.3.48-apiversion.diff' i can't see a change of this line.
>
> Jörg



More information about the vdr mailing list