[vdr] vdr-remote plugin not compiling???

Simon Baxter linuxtv at nzbaxters.com
Tue Apr 25 05:04:49 CEST 2006

>> Simon Baxter wrote:
>>> I've just downloaded vdr-remote-0.3.6, and it won't compile.
>>>  g++ -fPIC -g -O2 -Wall -Woverloaded-virtual -c -DPLUGIN_NAME_I18N='"remote"' 
>>>  -I/lib/modules/ remote.c
>>> /lib/modules/ error: 
>>> 'kernel_ulong_t' does not name a type
>> Since this kernel is quite fresh, maybe its an error in the kernel 
>> headers. Try pointing DVBDIR in Make.config to an older kernel header 
>> version. Or, if you upgrade to recent VDR, don't point to kernel headers 
>> at all. Since 1.3.47 VDR defaults to use /usr/include/input.h and 
>> similar.
>> Cheers,
>> Udo
> I've tried both - same error against older trees, and the upgrade to 
> 1.3.48 gives:
> Plugin remote:
> ERROR: plugin remote doesn't honor APIVERSION - not compiled!

-kept the vdr version 1.3.46
-removed the following lines from 'remote' Makefile:

#DVBDIR = ../../../../DVB
#include $(VDRDIR)/Make.config

bit of a hack, but it works now.... 

More information about the vdr mailing list