[vdr] (no subject)

Halim Sahin halim.sahin at t-online.de
Sat Aug 5 02:04:30 CEST 2006


Hi,

Placbakopen error? hmm
did you insert your vdr-user into audio group?
/etc/group
order 
adduser???

On Fr, Aug 04, 2006 at 09:39:38 +0200, Alex Golks wrote:
> at first, thanks alot for the help.
> perhaps i "not see the wood for the trees" (is this right in english). wanna say, perhaps im just too stupid...
> 
> here are some debuggin outputs, for just to be sure that alsa works for me:
> 
> cat /dev/urandom >/dev/dsp works, get this funny white noise out of my speakers.
> 
> alsamixer screen:
> ----------------------------------
> Card: C-Media PCI CMI8738-MC6
> Chip: CMedia PCI
> View: [Playback] Capture  All
> Item: Master
> ----------------------------------
> 
> $ cat /proc/asound/devices
>   0: [ 0]   : control
>   4: [ 0- 0]: hardware dependent
>  16: [ 0- 0]: digital audio playback
>  17: [ 0- 1]: digital audio playback
>  18: [ 0- 2]: digital audio playback
>  24: [ 0- 0]: digital audio capture
>  26: [ 0- 2]: digital audio capture
>  33:        : timer
>  
> $ cat /proc/asound/pcm
> 00-02: CMI8738-MC6 : C-Media PCI IEC958 : playback 1 : capture 1
> 00-01: CMI8738-MC6 : C-Media PCI 2nd DAC : playback 1
> 00-00: CMI8738-MC6 : C-Media PCI DAC/ADC : playback 1 : capture 1
> 
> --------------
> without -ao:
> --------------
> Dec 24 20:57:32 gockels-video vdr: [4525] [softdevice-audio] Opening alsa device default
> Dec 24 20:57:32 gockels-video vdr: [4525] [softdevice-audio] Using alsa AC3 device hw:0,1
> Dec 24 20:57:33 gockels-video vdr: [4525] [softdevice-audio] Playback open error: default, No such device FATAL exiting
> --------------
> with -ao alsa:pcm=default
> --------------
> Dec 24 20:59:19 gockels-video vdr: [4698] [softdevice-audio] Opening alsa device default
> Dec 24 20:59:19 gockels-video vdr: [4698] [softdevice-audio] Using alsa AC3 device hw:0,1
> Dec 24 20:59:19 gockels-video vdr: [4698] [softdevice-audio] Playback open error: default, No such device FATAL exiting
> --------------
> with -ao alsa:pcm=default#ac3=default#
> --------------
> Dec 24 21:01:37 gockels-video vdr: [4977] [softdevice-audio] Opening alsa device default
> Dec 24 21:01:37 gockels-video vdr: [4977] [softdevice-audio] Using alsa AC3 device hw:0,1
> Dec 24 21:01:37 gockels-video vdr: [4977] [softdevice-audio] Playback open error: default, No such device FATAL exiting
> --------------
> with -ao dummy:
> --------------
> Dec 24 21:03:30 gockels-video vdr: [5290] [softdevice-audio-dummy] Device opened! Ready to play
> 
> so, its true, i've no spdif output on this card. but when you can tell softdevice what $dev_name (as mentioned in the softdevice readme) it should use for ac3 output (for it insists on using this), where do i get the $dev_name from?
> my driver is called cmipci, doesn't work.
> /dev/dsp or audio doesn't work either...
> xine can do a down-mix, and i get sound from vdr with xine plugin for example.
> on the other hand, there was a time, when i had 5 speaker connected to this card and heard nice digital surround sound from a dvd.
> 
> i just can't get the idea behind all this (did i said this things about my foolischness?) 
> -- 
> 
> 
> Echte DSL-Flatrate dauerhaft für 0,- Euro*. Nur noch kurze Zeit!
> "Feel free" mit GMX DSL: http://www.gmx.net/de/go/dsl
> 
> _______________________________________________
> vdr mailing list
> vdr at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr

-- 
Halim Sahin
E-Mail:				
halim.sahin at t-online.de



More information about the vdr mailing list