[vdr] Re: Problem with vdr-1.4.4-1 and extrecmenu

Klaus Schmidinger Klaus.Schmidinger at cadsoft.de
Sun Dec 3 15:40:00 CET 2006


Suur Karu wrote:
> Peter Pinnau wrote:
>> I just applied the vdr-1.4.4-1 maintainance patch and some plugins 
>> failed to compile.
>> I could fix all problems within the plugins except for extrecmenu.
> 
> Please advise me how fix compile errors with remote and streamdev plugins.
> 
> Plugin streamdev:
> make[1]: Entering directory 
> `/usr/local/src/vdr-1.4.4-1/PLUGINS/src/streamdev'
> g++ -W -Woverloaded-virtual -O2 -c -D_GNU_SOURCE -DHAVE_AUTOPID 
> -I../../../include -I../../../../DVB/include -I. -o client/socket.o 
> client/socket.c
> client/socket.c: In member function `bool cClientSocket::Command(const 
> std::string&, uint, uint)':
> client/socket.c:57: error: `uint64' was not declared in this scope
> client/socket.c:57: error: expected `;' before "elapsed"
> client/socket.c:59: error: `elapsed' was not declared in this scope
> make[1]: *** [client/socket.o] Error 1
> ...

Add the line

#define uint64 uint64_t

to VDR/tools.h.

I'll add this in the next maintenance patch, too.
In the long run all plugins should change this to uint64_t, though.

Klaus



More information about the vdr mailing list