[vdr] xine changing OSD modes when switching channels

C.Y.M syphir at syphir.sytes.net
Mon Mar 13 13:29:18 CET 2006


Reinhard Nissl wrote:
> Hi,
> 
> Reinhard Nissl wrote:
> 
>>> When I switch channels in vdr-1.3.44, I noticed that xine-0.7.7 is
>>> switching OSD
>>> display modes during channel changes.  I am currently using "blend
>>> clipped" for
>>> the OSD display mode, but when I switch channels, xine temporarily
>>> goes into X11
>>> overlay mode in the middle of channel change, then goes back to the
>>> mode I have
>>> selected to use.  Any way of preventing xine from temporarily
>>> switching to "X11
>>> overlay" during channel changes?
>>
>> I haven't noticed such a behavior recently, but I'll have a look at it
>> tomorrow evening.
> 
> Are you sure that it is "X11 overlay mode" (this mode doesn't support
> semi transparent colors)?
> 
> When switching channels, vdr-xine shows the NO SIGNAL screen which has a
> resolution of 720x576. If your channels broadcast at a different
> resolution then that, you get the visual effect of using "X11 overlay
> mode" while NO SIGNAL is shown, but the difference is, that the OSD is
> still semi transparent (assuming that support for semi transparent
> colors is enabled in vdr-xine's setup menu).
> 
> As it is now easier to create noSignal.mpg, you may create such a single
> image mpg at a resolution which suits better for your channels.
> 

Reinhard, you were absolutely correct.  Since most of the broadcast here is done
in 544x480, all I had to do was change the no-signal mpeg file to the correct
resolution and aspect ratio (4/3) and now it looks perfect when switching
channels.  Thanks for explaining that to me and sorry for the trouble.

Best Regards,



More information about the vdr mailing list