[vdr] mp3 plugin gcc 4.1 fix

Sean Carlos sean.carlos at gmail.com
Wed Mar 29 12:02:47 CEST 2006


The attached patch allows the mp3 plugin to compile with gcc 4.1 (i.e. 
Fedora core 5) - to avoid "extra qualification 'foo::' on member 'bar'" 
errors.

It shamelessly follows the changes made to the epgsearch plugin by 
Darren Salt.

I don't know C, I just know how to follow a pattern; it worked for me 
but there may/will be room for improvement.

Sean

Ref: http://www.muempf.de/vdr-mp3.html


-------------- next part --------------
A non-text attachment was scrubbed...
Name: mp3-0.9.14-gcc41.patch.gz
Type: application/x-gzip
Size: 334 bytes
Desc: not available
Url : http://www.linuxtv.org/pipermail/vdr/attachments/20060329/5ef533ca/mp3-0.9.14-gcc41.patch.bin


More information about the vdr mailing list