[vdr] softdevice and epia tv-out problem with Xorg

Stefan Lucke stefan at lucke.in-berlin.de
Thu Nov 2 23:38:54 CET 2006


Quoting Leo Márquez:

> Hi again,
>
> Stefan Lucke escribió:
>
> >>/ But after started it without problems now I get:
> >/>/
> >/>/ [softdevice] A/V devices initialized, now initializing MPEG2 Decoder
> >/>/ X Error of failed request:  BadValue (integer parameter out of range for
> >/>/ operation)
> >/>/   Major opcode of failed request:  145 (MIT-SHM)
> >/>/     Minor opcode of failed request:  3 (X_ShmPutImage)
> >/>/       Value in failed request:  0x3ff
> >/
> >Which are the startup options now ?
> >0x3ff = 1023 = 1024 - 11
> >
> >
> My startup options are only "-vo xv:full"
>
> >Did you changed your X resolution via "ALT"+"CTRL"+"Keypad +" ?
> >
> >
> No but I press the 'f' key to toggle between fullscreen and windowed vdr
> mode.
> The second time I run vdr with -vo xv:full don't work

Ah, I should have mentioned that you _must_ not toggle full screen ->
windowed mode, as windowed mode works with some default values
which even did not work previously (thats why I ask for full screen mode).

I'll send you a patch tomorrow that will restrict these values.

>
> >can you show us the output of command xdpyinfo ?
> >
> >
> My xdpyinfo output command Is here:
>
> name of display:    :0.0
> version number:    11.0
> vendor string:    The X.Org Foundation
> vendor release number:    70101000
> X.Org version: 7.1.1

> number of screens:    1
>
> screen #0:
>   dimensions:    720x576 pixels (183x146 millimeters)
>   resolution:    100x100 dots per inch
>   depths (7):    24, 1, 4, 8, 15, 16, 32

The resolution and #of screens I wanted to see (no further hint).

> >Which osd_image size was reported in that case ?
> >
> >
> [setup-softdevice] startup aspect set to (16:9 wide)
> [softdevice] initializing Plugin
> [softdevice] Initializing Video Out
> [softdevice] ffmpeg build(3345920)
> [XvVideoOut]: osd_image shmid = 2129920
> [XvVideoOut]: got osd_image: width 720 height 576, bytes per line 2880
> [softdevice] Subplugin successfully opend
> [softdevice] Video Out seems to be OK
> [softdevice] Initializing Audio Out
> [softdevice] Audio out seems to be OK
> [softdevice] A/V devices initialized, now initializing MPEG2 Decoder
> X Error of failed request:  BadValue (integer parameter out of range for
> operation)
>   Major opcode of failed request:  145 (MIT-SHM)
>     Minor opcode of failed request:  3 (X_ShmPutImage)
>       Value in failed request:  0x3ff
>         Serial number of failed request:  250
>           Current serial number in output stream:  251
>
> Another issue that I don't know if is related with the main topic is
> that when I start vdr correctly (only the first time) I don't get video.
> I'm using streamdev-client. In syslog I see:
>
> [XvVideoOut]: (ERROR) could not grab any port! No video possible!

Oh, then I misunderstood you. Thought the it works the first time
you called it.
So did you ever or never get video ?

I like to ask for output of: xdpyinfo .

>
> Thank you for you attention.

Stefan Lucke



More information about the vdr mailing list