[vdr] xineliboutput letterbox & mplayer problems

Simon Baxter linuxtv at nzbaxters.com
Tue Nov 7 17:55:04 CET 2006


I've been trying xineliboutput for the first time - looks like it will solve 
all sorts of problems I've been having, if I can get over these ones....

Problem number 1:
If I start the plugin with :
vdr -P"xineliboutput --local=sxfe --video=xv --audio=alsa --remote=none"

I get a letterbox window in the middle of the gnome screen.  So I tried:
-P'xineliboutput --fullscreen --local=sxfe --video=xxmc --audio=alsa --remote=none'

This gives me the same as above, but with black borders filling the screen. 
Still a much smaller picture than the full screen I get with vdr-xine.
Also, when I change channels (PVR with pvrinput plugin) the various channel 
scaling leaves parts of the picture around the new "letterbox" image.

How do I set scaling?  When I use vdr-xine, I start it with 
"xine --fullscreen --hide-gui -V xv -A alsa -D --post vdr_video --post 
vdr_audio vdr://tmp/vdr-xine/stream#demux:mpeg_pes"


Problem number 2:
I have been using the mplayer plugin to play divx/xvid/mpeg movies.  It's 
rather clumsy though, as I need to kill xine and restart after (scripted) to 
free up the xxmc/xvmc resources.
When I try and play an avi file with xineliboutput, I get stuttering video 
and loads of the following:
bad_frame
[mpeg4 @ 0x125b4e4]header damaged


What does work well, which I'm VERY pleased with, is DVD playback.  I've had 
a long standing problem with intermittant audio stuttering - which seems to 
be resolved with xineliboutput! 




More information about the vdr mailing list