[vdr] xineliboutput letterbox & mplayer problems

Petri Hintukainen Petri.Hintukainen at hut.fi
Sun Nov 12 08:37:47 CET 2006


On Tue, 2006-11-07 at 08:55 -0800, Simon Baxter wrote:
> I've been trying xineliboutput for the first time - looks like it will solve 
> all sorts of problems I've been having, if I can get over these ones....
> 
> Problem number 1:
> If I start the plugin with :
> vdr -P"xineliboutput --local=sxfe --video=xv --audio=alsa --remote=none"
> 
> I get a letterbox window in the middle of the gnome screen.  So I tried:
> -P'xineliboutput --fullscreen --local=sxfe --video=xxmc --audio=alsa --remote=none'
> 

You might want to try the options for display aspect ratio and
letterbox->16:9 scaling ? With vdr-sxfe, tou can try aspect ratios 4:3,
16:9 or 16:10 (--help).
If you want to have "real" 16:9 out of "letterboxed" image, correctly
scaled, please try --post=autoscale option (with possible sub-options of
your taste). 
autoscale is shipped (and installed?) with xineliboutput package. 

> This gives me the same as above, but with black borders filling the screen. 
> Still a much smaller picture than the full screen I get with vdr-xine.
> Also, when I change channels (PVR with pvrinput plugin) the various channel 
> scaling leaves parts of the picture around the new "letterbox" image.
I'd say this is in fact the same problem ?
> How do I set scaling?  When I use vdr-xine, I start it with 
> "xine --fullscreen --hide-gui -V xv -A alsa -D --post vdr_video --post 
> vdr_audio vdr://tmp/vdr-xine/stream#demux:mpeg_pes"

Check vdr-sxfe and --help output.
You can try to fix some of the incorrect scaling problems with different
options in menu -> VDR plugins / xineliboutput / OSD menu. Anyway, there
is not much to do unless you use vdr-sxfe or vdr-fbfe and correct
--aspect option - YOUR frontend for output.

> Problem number 2:
> I have been using the mplayer plugin to play divx/xvid/mpeg movies.  It's 
> rather clumsy though, as I need to kill xine and restart after (scripted) to 
> free up the xxmc/xvmc resources.
> When I try and play an avi file with xineliboutput, I get stuttering video 
> and loads of the following:
> bad_frame
> [mpeg4 @ 0x125b4e4]header damaged

I belive this is quite usual ; if someone else has any other info, pse
speak now :) I got it with almost all "net" and transcoded dc-camera
mpeg4 video clips, even up to 200 lines / sec disorientation. I use the
magical  &> /dev/null  options in all scripts to nuke it - typically the
error message uses too much CPU to even access any VDR menus.. Anyway,
it is xine mpeg4 decoder probem. As those clips still play 100% (unless
you add in the addtional 20%...100% "optional" CPU usage I'm quite happy
with current decdoer.
It might help (for CPU ...) if you start sxfe with >&/dev/null. (for me
it is just enough :). 
And, I like to lay on the sand+sun when VDR is running smoothly :)

> What does work well, which I'm VERY pleased with, is DVD playback.  I've had 
> a long standing problem with intermittant audio stuttering - which seems to 
> be resolved with xineliboutput! 
> 

vdf-xineliboutput has own dvd player, it uses xine to playu DVDs.
If you have any serious problems with DVDs, please call/mail me.

As told in the readme, most of the features are not available unless you
use vdr-sxfe frontend to connect to VDR.

BTW, there are some quite significant improvements for DVD playback in
the next version (or CVS :)

"offically" there is no support for using xine, gxine, ... ui's as
xineliboutput frontend - I'll give any help I can but I won't try
anything. Most of the features are just unacceblible from VDR when
using ?xine? ... but with some script magic (?) it is still possible if
Y know what Y are doing.

- Petri


- Petri






More information about the vdr mailing list