[vdr] Problem to get vdr-to-vdr streaming working...

Juha Pahkala jpahka at welho.com
Wed Nov 22 07:26:26 CET 2006


I've been trying to get vdr-to-vdr (both version 1.4.4) streaming
working with streamdev (cvs from last sunday) for the past couple of
days. I've tweaked the different settings but can't get the streaming to
work. As a side note, http streaming is working without problems, so
there's something I've done correctly. Anyhow, when trying to stream
vdr-to-vdr, this is what I get on the server side:

Nov 21 18:04:08 remote vdr: [7517] Streamdev: Accepted new client (VTP)
192.168.0.119:37794
Nov 21 18:04:19 remote vdr: [7517] Streamdev: Setting data connection to
192.168.0.119:44312


And this is on the client side:

Nov 21 18:04:06 localhost vdr: [5870] VDR version 1.4.4 started
Nov 21 18:04:06 localhost vdr: [5870] loading plugin:
./PLUGINS/lib/libvdr-softdevice.so.1.4.4
Nov 21 18:04:07 localhost vdr: [5870] loading plugin:
./PLUGINS/lib/libvdr-streamdev-client.so.1.4.4
Nov 21 18:04:07 localhost vdr: [5870] loading
/home/user/.vdr/video/setup.conf
Nov 21 18:04:07 localhost vdr: [5870] ERROR: unknown config parameter:
softdevice.Postprocess Method = 0
Nov 21 18:04:07 localhost vdr: [5870] ERROR: unknown config parameter:
softdevice.Postprocess Quality = 0
Nov 21 18:04:07 localhost vdr: [5870] loading
/home/user/.vdr/video/sources.conf
Nov 21 18:04:07 localhost vdr: [5870] loading
/home/user/.vdr/video/channels.conf
Nov 21 18:04:07 localhost vdr: [5870] loading
/home/user/.vdr/video/remote.conf
Nov 21 18:04:07 localhost vdr: [5870] reading EPG data from
/home/user/.vdr/video/epg.data
Nov 21 18:04:07 localhost vdr: [5871] video directory scanner thread
started (pid=5870, tid=5871)
Nov 21 18:04:07 localhost vdr: [5872] video directory scanner thread
started (pid=5870, tid=5872)
Nov 21 18:04:07 localhost vdr: [5871] video directory scanner thread
ended (pid=5870, tid=5871)
Nov 21 18:04:07 localhost vdr: [5872] video directory scanner thread
ended (pid=5870, tid=5872)
Nov 21 18:04:07 localhost vdr: [5870] no DVB device found
Nov 21 18:04:07 localhost vdr: [5870] initializing plugin: softdevice
(0.3.1): A software emulated MPEG2 device
Nov 21 18:04:07 localhost vdr: [5870] [XvVideoOut]: patch version
(2006-11-05)
Nov 21 18:04:07 localhost vdr: [5870] [XvVideoOut]: Initialize
XShmCreateImage Successful (0xb65bbcd0)
Nov 21 18:04:07 localhost vdr: [5870] [XvVideoOut]: Initialize shmget
Successful (2949120 bytes)
Nov 21 18:04:07 localhost vdr: [5870] [XvVideoOut]: Initialize shmat
Successful
Nov 21 18:04:08 localhost vdr: [5870] [softdevice-xscreensaver]:
xscreensaver not running
Nov 21 18:04:08 localhost vdr: [5870] [XvVideoOut]: initialized OK
Nov 21 18:04:08 localhost vdr: [5870] [XvVideoOut]: Intel(R) Video
Overlay: available ports 73 - 73
Nov 21 18:04:08 localhost vdr: [5870] [XvVideoOut]: grabbed port 73
Nov 21 18:04:08 localhost vdr: [5870] [XvVideoOut]: max area size 1920 x
1080
Nov 21 18:04:08 localhost vdr: [5870] [XvVideoOut]: using area size 736
x 576
Nov 21 18:04:08 localhost vdr: [5870] [XvVideoOut]:  
XV_COLORKEY                   XvGettable     XvSettable (       0
[0x00000000] - 16777215 [0x00ffffff]) (   66046 [0x000101fe]
Nov 21 18:04:08 localhost vdr: [5870] [XvVideoOut]:  
XV_BRIGHTNESS                 XvGettable     XvSettable (    -128
[0xffffff80] -      127 [0x0000007f]) (       0 [0x00000000]
Nov 21 18:04:08 localhost vdr: [5870] [XvVideoOut]:  
XV_CONTRAST                   XvGettable     XvSettable (       0
[0x00000000] -      255 [0x000000ff]) (      64 [0x00000040]
Nov 21 18:04:08 localhost vdr: [5870] [XvVideoOut]:  
XV_DOUBLE_BUFFER              XvGettable     XvSettable (       0
[0x00000000] -        1 [0x00000001]) (       1 [0x00000001]
Nov 21 18:04:08 localhost vdr: [5870] [XvVideoOut]:  
XV_GAMMA0                     XvGettable     XvSettable (       0
[0x00000000] - 16777215 [0x00ffffff]) (  526344 [0x00080808]
Nov 21 18:04:08 localhost vdr: [5870] [XvVideoOut]:  
XV_GAMMA1                     XvGettable     XvSettable (       0
[0x00000000] - 16777215 [0x00ffffff]) ( 1052688 [0x00101010]
Nov 21 18:04:08 localhost vdr: [5870] [XvVideoOut]:  
XV_GAMMA2                     XvGettable     XvSettable (       0
[0x00000000] - 16777215 [0x00ffffff]) ( 2105376 [0x00202020]
Nov 21 18:04:08 localhost vdr: [5870] [XvVideoOut]:  
XV_GAMMA3                     XvGettable     XvSettable (       0
[0x00000000] - 16777215 [0x00ffffff]) ( 4210752 [0x00404040]
Nov 21 18:04:08 localhost vdr: [5870] [XvVideoOut]:  
XV_GAMMA4                     XvGettable     XvSettable (       0
[0x00000000] - 16777215 [0x00ffffff]) ( 8421504 [0x00808080]
Nov 21 18:04:08 localhost vdr: [5870] [XvVideoOut]:  
XV_GAMMA5                     XvGettable     XvSettable (       0
[0x00000000] - 16777215 [0x00ffffff]) (12632256 [0x00c0c0c0]
Nov 21 18:04:08 localhost vdr: [5870] [XvVideoOut]: XvShmCreateImage
Successful (0xb65bc5a8)
Nov 21 18:04:08 localhost vdr: [5870] [XvVideoOut]: shmget Successful (0
bytes)
Nov 21 18:04:08 localhost vdr: [5870] [XvVideoOut]: shmat Successful
Nov 21 18:04:08 localhost vdr: [5870] [XvVideoOut]: XShmAttach    rc = 1
(should be OK)
Nov 21 18:04:08 localhost vdr: [5870] [softdevice] videoOut OK !
Nov 21 18:04:08 localhost vdr: [5870] [softdevice-audio] Opening alsa
device default
Nov 21 18:04:08 localhost vdr: [5870] [softdevice-audio] Using alsa AC3
device hw:0,1
Nov 21 18:04:08 localhost vdr: [5870] [softdevice-audio] Device opened!
Ready to play
Nov 21 18:04:08 localhost vdr: [5870] initializing plugin:
streamdev-client (0.3.3-pre3-geni): VTP Streaming Client
Nov 21 18:04:08 localhost vdr: [5870] setting primary device to 1
Nov 21 18:04:08 localhost vdr: [5870] SVDRP listening on port 2001
Nov 21 18:04:08 localhost vdr: [5870] setting current skin to "sttng"
Nov 21 18:04:08 localhost vdr: [5870] loading
/home/user/.vdr/video/themes/sttng-default.theme
Nov 21 18:04:08 localhost vdr: [5870] starting plugin: softdevice
Nov 21 18:04:08 localhost vdr: [5870] starting plugin: streamdev-client
Nov 21 18:04:08 localhost vdr: [5870] reading EPG data from
/home/user/.vdr/video/epg.data
Nov 21 18:04:08 localhost vdr: [5877] section handler thread started
(pid=5870, tid=5877)
Nov 21 18:04:08 localhost vdr: [5876] streamdev-client: sections
assembler thread started (pid=5870, tid=5876)
Nov 21 18:04:08 localhost vdr: [5870] Streamdev: Connected to server
192.168.0.1:2004 using capabilities TSPIDS
Nov 21 18:04:08 localhost vdr: [5870] Streamdev: Synchronizing EPG from
server
Nov 21 18:04:08 localhost vdr: [5873] [VideoOut]: 736x576 [0,0 736x576]
-> 1024x576 [118,0 788x576]
Nov 21 18:04:08 localhost vdr: [5873] [VideoOut]: 736x576 [0,0 736x576]
-> 1024x576 [118,0 788x576]
Nov 21 18:04:09 localhost vdr: [5870] remote control softdevice-xv -
keys known
Nov 21 18:04:09 localhost vdr: [5870] remote control KBD - learning keys
Nov 21 18:04:09 localhost vdr: [5880] KBD remote control thread started
(pid=5870, tid=5880)
Nov 21 18:04:19 localhost vdr: [5870] switching to channel 27
Nov 21 18:04:19 localhost vdr: [5870] Streamdev: Filter 18, 78, 254 not
available from 192.168.0.119:37794
Nov 21 18:04:19 localhost vdr: [5870] Streamdev: Filter 18, 80, 240 not
available from 192.168.0.119:37794
Nov 21 18:04:19 localhost vdr: [5870] Streamdev: Filter 18, 96, 240 not
available from 192.168.0.119:37794
Nov 21 18:04:19 localhost vdr: [5870] Streamdev: Filter 20, 112, 255 not
available from 192.168.0.119:37794
Nov 21 18:04:19 localhost vdr: [5870] Streamdev: Filter 0, 0, 255 not
available from 192.168.0.119:37794
Nov 21 18:04:19 localhost vdr: [5870] Streamdev: Filter 17, 66, 255 not
available from 192.168.0.119:37794
Nov 21 18:04:19 localhost vdr: [5870] Streamdev: Filter 16, 64, 255 not
available from 192.168.0.119:37794
Nov 21 18:04:19 localhost vdr: [5887] receiver on device 6 thread
started (pid=5870, tid=5887)
Nov 21 18:04:19 localhost vdr: [5886] transfer thread started (pid=5870,
tid=5886)
Nov 21 18:04:21 localhost vdr: [5887] Streamdev: Lost connection to
192.168.0.1:2004: Connection timed out
Nov 21 18:04:21 localhost vdr: [5887] receiver on device 6 thread ended
(pid=5870, tid=5887)
Nov 21 18:04:31 localhost vdr: [5873] [VideoOut]: 736x576 [0,0 736x576]
-> 1024x576 [118,0 788x576]
Nov 21 18:04:31 localhost vdr: [5880] KBD remote control thread ended
(pid=5870, tid=5880)


Anybody able to tell from these, what's going wrong? The server side
seems awfully quiet is syslog, maybe something wrong there? Anyway to
debug this more closely?

Thanks, Juhis






More information about the vdr mailing list