[vdr] [ANNOUNCE] po2i18n - converter for plugin backwards compatibility

Dieter Hametner dh+vdr at gekrumbel.de
Sun Aug 19 18:33:32 CEST 2007


Hi

Am Sonntag, 19. August 2007 schrieb Udo Richter:
> Dieter Hametner wrote:
> > I kind of enhanced your script to use the CPAN module Locale::PO for
> > reading the .po/.pot files. Your implementation did not handle multi line
> > msgids and msgstrs well.
>
> Hmmm, ok, I don't have multi-line strings that need translation, but
> this is probably worth a fix.
> But I don't really want to depend on Locale::PO, as it is not very
> likely to be installed on systems out there.

I'm aware of that. Debian sid has also an outdated package for it 
('liblocale-po-perl' version 0.15 where as in CPAN it is version 0.17).

Still I think building on others work is one of the spirits of open source :)

>
> > My change adds all strings in the plugins .pot file to the resulting
> > i18n.c file, even when no translation exists for the string and it does
> > not sort the msgids.
>
> Since all po files get updated too all the time, reading the pot file is
> not really necessary.

With the Locale::PO package I needed a file where I would know of, that all 
possible strings appear because the single .po files don't get merged 
together.

Regards

Dieter

-- 
Dieter Hametner                    dh (plus) vdr (at) gekrumbel (dot) de
live plugin developer              http://live.vdr-developer.org



More information about the vdr mailing list