[vdr] VDR 1.5.4+ crashes

vdr at digestive.jpl.se vdr at digestive.jpl.se
Sat Dec 29 23:43:24 CET 2007


Hi!

I'm having a problem with that VDR version 1.5.4 and newer crashes as 
fast as I tries to start them. See below - I have read through the 
changelog but I have no idea what might cause my segfaults.

Dec 29 23:28:15 radiokaka vdr: [1078] VDR version 1.5.4 started
Dec 29 23:28:15 radiokaka vdr: [1078] codeset is 'ANSI_X3.4-1968' - 
unknown
Dec 29 23:28:15 radiokaka vdr: [1078] loading plugin: 
./PLUGINS/lib/libvdr-xine.so.1.5.4
Dec 29 23:28:15 radiokaka vdr: [1078] loading /etc/vdr/setup.conf
Dec 29 23:28:15 radiokaka vdr: [1078] ERROR: unknown config parameter: 
MenuButtonCloses = 0
Dec 29 23:28:15 radiokaka vdr: [1078] loading /etc/vdr/sources.conf
Dec 29 23:28:15 radiokaka vdr: [1078] loading /etc/vdr/diseqc.conf
Dec 29 23:28:15 radiokaka vdr: [1078] loading /etc/vdr/channels.conf
Dec 29 23:28:15 radiokaka vdr: [1078] loading /etc/vdr/svdrphosts.conf
Dec 29 23:28:15 radiokaka vdr: [1079] video directory scanner thread 
started (pid=1078, tid=1079)
Dec 29 23:28:15 radiokaka vdr: [1079] video directory scanner thread 
ended (pid=1078, tid=1079)
Dec 29 23:28:15 radiokaka vdr: [1080] video directory scanner thread 
started (pid=1078, tid=1080)
Dec 29 23:28:15 radiokaka vdr: [1080] video directory scanner thread 
ended (pid=1078, tid=1080)
Dec 29 23:28:15 radiokaka vdr: [1078] reading EPG data from 
/video/epg.data
Dec 29 23:28:15 radiokaka vdr: [1078] probing 
/dev/dvb/adapter0/frontend0
Dec 29 23:28:15 radiokaka vdr: [1082] tuner on device 1 thread started 
(pid=1078, tid=1082)
Dec 29 23:28:15 radiokaka vdr: [1083] section handler thread started 
(pid=1078, tid=1083)
Dec 29 23:28:15 radiokaka vdr: [1078] found 1 video device
Dec 29 23:28:15 radiokaka vdr: [1078] initializing plugin: xine (0.8.0): 
Software based playback using xine
Dec 29 23:28:15 radiokaka vdr: [1084] XineRemote control thread started 
(pid=1078, tid=1084)
Dec 29 23:28:15 radiokaka vdr: [1084] Entering cXineRemote thread
Dec 29 23:28:15 radiokaka vdr: [1078] setting primary device to 2
Dec 29 23:28:16 radiokaka vdr: [1078] assuming manual start of VDR
Dec 29 23:28:16 radiokaka vdr: [1078] SVDRP listening on port 2001
Dec 29 23:28:16 radiokaka vdr: [1078] setting current skin to "sttng"
Dec 29 23:28:16 radiokaka vdr: [1078] loading 
/etc/vdr/themes/sttng-default.theme
Dec 29 23:28:16 radiokaka vdr: [1078] starting plugin: xine
Dec 29 23:28:16 radiokaka vdr: [1078] ERROR: remote control XineRemote 
not ready!
Dec 29 23:28:16 radiokaka vdr: [1078] switching to channel 1
Dec 29 23:28:16 radiokaka vdr: [1088] transfer thread started (pid=1078, 
tid=1088)
Dec 29 23:28:16 radiokaka vdr: [1089] receiver on device 1 thread 
started (pid=1078, tid=1089)
Dec 29 23:28:16 radiokaka vdr: [1090] TS buffer on device 1 thread 
started (pid=1078, tid=1090)
Dec 29 23:28:16 radiokaka vdr[1078] general protection rip:2ac025871bc8 
rsp:7fff85923740 error:0

(it crashes without the xine-plugin as well)

I had the same problems with 1.5.3 before I copied arial.ttf and 
arialbd.ttf to /usr...truetype/

Thanks for any help,

Best regards Lars Fredriksson



More information about the vdr mailing list