[vdr] [RFC] Shutdown rewrite for 1.5.x
Klaus.Schmidinger at cadsoft.de
Sun Jan 28 21:21:54 CET 2007
Udo Richter wrote:
> Klaus Schmidinger wrote:
>> I would suggest to rename NextWakeupEvent() to WakeupTime(), because
>> there isn't really an "event" involved, and the word "event is generally
>> used in a different context (for EPG events). Plus, the individual
>> plugin only has a single wake-up time, so there's no need for "Next".
>> Accordingly GetNextWakeupEventPlugin() should be renamed to
>> GetNextWakeupPlugin(). Here the "Next" makes sense, because the
>> function returns the plugin with the earliest wake-up time. The
>> "Time" part could be dropped because the function returns a cPlugin*
>> and there is no time involved.
> I agree, s/event/time/g makes things a lot more consistent. I didn't
> like GetNextWakeupEventPlugin either.
> I also renamed the setup parameter NextWakeupEvent to NextWakeupTime,
> and renamed some local variables accordingly. I can provide a patch if
I'll wait for the final result for version 1.5, once everybody
has agreed on it ;-)
More information about the vdr