[vdr] mplayer-plugin can't play h264 .ts file

Igor goga777 at bk.ru
Tue Jul 10 20:49:35 CEST 2007


Hello

I can't play by mplayer-plugin the h264-video .ts file with standard definition. But with 
command mplayer -vo mpegpes -ao mpegpes -nolirc -msglevel all=5 /data/mplayer/video/1muz.ts
everything is ok

arvdr://data/mplayer/Mult# /usr/bin/mplayer -vo mpegpes -ao mpegpes -nolirc -msglevel
all=5 /data/mplayer/video/1muz.ts 

MPlayer 1.0pre8-3.3.5 (C) 2000-2006 MPlayer Team
CPU: AMD Sempron(tm) Processor 2800+ (Family: 15, Model: 44, Stepping: 2)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Playing /data/mplayer/video/1muz.ts.
TS file format detected.
DEMUX OPEN, AUDIO_ID: -1, VIDEO_ID: -1, SUBTITLE_ID: -2,
PROBING UP TO 2000000, PROG: 0
VIDEO H264(pid=538)...AUDIO MPA(pid=725) NO SUBS (yet)!  PROGRAM N. 18
Opened TS demuxer, audio: 50(pid 725), video: 10000005(pid 538)...POS=752, PROBE=2000000
FPS seems to be: 25.000000
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
Opening /dev/dvb/adapter0/video0+audio0
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
AO: [mpegpes] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 720 x 576 (preferred colorspace: Planar YV12)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
Opening video filter: [lavc]
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.36:1 - prescaling to correct movie aspect.
[mpeg1video @ 0x86b8c00]removing common factors from framerate
VO: [mpegpes] 720x576 => 786x576 Mpeg PES
A:92660.3 V:92661.6 A-V: -1.371 ct: -0.196  50/ 50 34% 45%  0.4% 0 0


Hereafter there's   unsuccessful log with mplayer-plugin

Jul 12 00:30:01 arvdr logger: *** Starting mplayer.sh Version 0.8.7
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable CFGFIL has value "/usr/bin/mplayer.sh.conf"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable USEAC3 has value "false"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable AC3AOUT has value "-ac hwac3"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable TV_ASPECT has value "4/3"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable PAL has value "true"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable NTSC has value "true"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable USE_SPEED has value "false"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable DETC_FILTER has value "detc=dr=2:am=1"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable MPLAYER has value "/usr/bin/mplayer"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable VOP has value "lavc=5000"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable VO has value "mpegpes:card=1"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable AO has value "mpegpes:card=1"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable CACHE has value "15777"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable CACHESTR has value "-cache 15777"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable FRAMEDROP has value "false"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable FDSTR has value ""
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable LIRCRC has value "/video/.lircrc"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable LIRCSTR has value "-lircconf /video/.lircrc"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable SUBTITLE has value " -subpos 80 -sub-bg-color 0
-sub-bg-alpha 30"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable REMOTE has value "-slave -nolirc"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable USERDEF has value ""
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable XResPAL has value "352 480 528 544 704 720"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable XResNTSC has value "352 480 512 544 640 704 720"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable SLOW_CPU has value "false"
Jul 12 00:30:01 arvdr logger: *** DEBUG: *** Option DVDFiles not set correctly! You will not be able to
play VCD/DVD ""
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable DVDFiles has value ""
Jul 12 00:30:01 arvdr logger: *** DEBUG: *** Option DVD not set correctly! You will not be able to play
VCD/DVD ""
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable DVD has value ""
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable DVDLANG has value "en"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable DVDOPTIONS has value ""
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable VCDOPTIONS has value ""
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable MPEG_DIRECT has value "true"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable SUFFIX has value "z.ts"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Variable MPLAYER_V1 has value "true"
Jul 12 00:30:01 arvdr logger: *** DEBUG: Calling getvidxy function to analyze source video stream ...
Jul 12 00:30:01 arvdr lircd-0.8.0[7419]: accepted new client on /dev/lircd
Jul 12 00:30:01 arvdr lircd-0.8.0[7419]: removed client
Jul 12 00:30:01 arvdr logger: *** DEBUG: MPLAYER_RETURN:  "0"
Jul 12 00:30:01 arvdr logger: *** DEBUG: parsed output for ORIG_X: "0"
Jul 12 00:30:02 arvdr logger: *** DEBUG: parsed output for ORIG_Y: "0"
Jul 12 00:30:02 arvdr logger: *** DEBUG: parsed output for ORIG_FPS: "25.000"
Jul 12 00:30:02 arvdr logger: *** DEBUG: parsed output for ORIG_ASPECT: "0.0000"
Jul 12 00:30:02 arvdr logger: *** DEBUG: parsed output for VIDEO_FORMAT: "0x10000005"
Jul 12 00:30:02 arvdr logger: *** DEBUG: parsed output for AUDIO_CODEC: "mp3"
Jul 12 00:30:02 arvdr logger: *** INFO: Source Video has Resolution of 0 x 0 ...
Jul 12 00:30:02 arvdr logger: *** FATAL: something went wrong analyzing the video; check your mplayer
version ...
Jul 12 00:30:05 arvdr vdr: [7564] mplayer: player thread ended (pid=7564)


I don't understand why there's this messages

Jul 12 00:30:01 arvdr logger: *** DEBUG: parsed output for ORIG_X: "0"
Jul 12 00:30:02 arvdr logger: *** DEBUG: parsed output for ORIG_Y: "0"

could you anybody help to me ?

Igor













More information about the vdr mailing list