[vdr] CAM-CI and multi-channel viewing + slow startup

Klaus Schmidinger Klaus.Schmidinger at cadsoft.de
Sat Jul 21 14:16:01 CEST 2007


On 07/21/07 12:50, Simon Baxter wrote:
> Hi.
> 
> I have just got a TechnoTrend 1500-C budget with CI and Irdeto CAM working
> with vdr-1.5.5.
> 
> I was hoping to be able to view and record multiple channels in a
> boquet/transponder (as I've previously done with a dvb-t card and freeview).
> All my channels under dvb-c are encrypted:
> 
> Sky 1;T:594000:C0M64:C:XXXX:529:530:0:606:201:182:2:0
> Juice 2;T:594000:C0M64:C:XXXX:577:578:0:606:204:182:2:0
> 
> When I try and record 1 and watch/record the other I get:
> 
> 
> Jul 21 22:37:46 media1 vdr: [5680] record
> /media/video/vdr/@J2_-_Our_Kind_of_Music_Press_'i'_for_more_information./200
> 7-07-21.22.37.50.99.rec
> Jul 21 22:37:46 media1 vdr: [5680] info: Recording started
> Jul 21 22:37:50 media1 vdr: [5680] switching to channel 1
> Jul 21 22:37:51 media1 vdr: [5680] info: Channel not available!
> Jul 21 22:37:53 media1 vdr: [5680] switching to channel 2
> 
> 
> Is there anything I can do to get this working?
> 
> Also - when vdr starts up initially, it takes about 20 seconds before I get
> a picture:
> 
> Jul 21 22:44:37 media1 vdr: [5764] VDR version 1.5.5 started
> Jul 21 22:44:37 media1 vdr: [5764] codeset is 'ISO-8859-1' - known
> Jul 21 22:44:37 media1 vdr: [5764] loading plugin:
> ./PLUGINS/lib/libvdr-xine.so.1.5.5
> Jul 21 22:44:37 media1 vdr: [5764] loading
> /media/video/vdr-1.3.36/setup.conf
> Jul 21 22:44:37 media1 vdr: [5764] ERROR: unknown config parameter:
> MenuButtonCloses = 0
> Jul 21 22:44:37 media1 vdr: [5764] ERROR: unknown config parameter:
> SortTimers = 1
> Jul 21 22:44:37 media1 vdr: [5764] loading
> /media/video/vdr-1.3.36/sources.conf
> Jul 21 22:44:37 media1 vdr: [5764] loading
> /media/video/vdr-1.3.36/channels.conf
> Jul 21 22:44:37 media1 vdr: [5764] loading
> /media/video/vdr-1.3.36/timers.conf
> Jul 21 22:44:37 media1 vdr: [5764] loading
> /media/video/vdr-1.3.36/remote.conf
> Jul 21 22:44:37 media1 vdr: [5768] CAM 1: module present
> Jul 21 22:44:38 media1 vdr: [5764] found 1 video device
> Jul 21 22:44:38 media1 vdr: [5764] initializing plugin: xine (0.7.9):
> Software based playback using xine
> Jul 21 22:44:38 media1 vdr: [5764] setting primary device to 2
> Jul 21 22:44:38 media1 vdr: [5764] SVDRP listening on port 2001
> Jul 21 22:44:38 media1 vdr: [5764] setting current skin to "sttng"
> Jul 21 22:44:38 media1 vdr: [5764] loading
> /media/video/vdr-1.3.36/themes/sttng-default.theme
> Jul 21 22:44:38 media1 vdr: [5764] starting plugin: xine
> Jul 21 22:44:38 media1 vdr: [5764] ERROR: remote control XineRemote not
> ready!
> Jul 21 22:44:40 media1 kernel: dvb_ca adapter 0: DVB CAM detected and
> initialised successfully
> Jul 21 22:44:40 media1 vdr: [5768] CAM 1: module ready
> Jul 21 22:44:42 media1 vdr: [5768] CAM 1: Irdeto Access, 01, 06FF, 06FF
> Jul 21 22:44:47 media1 vdr: [5764] switching to channel 2
> Jul 21 22:44:47 media1 vdr: [5764] info: Channel not available!
> Jul 21 22:44:49 media1 vdr: [5764] switching to channel 1
> Jul 21 22:44:49 media1 vdr: [5764] info: Channel not available!
> Jul 21 22:44:49 media1 vdr: [5764] ERROR: Channel not available!
> Jul 21 22:45:02 media1 vdr: [5764] switching to channel 1
> Jul 21 22:45:04 media1 vdr: [5764] retuning due to modification of channel 1

Does your log contain any of these lines?:

Jul 21 12:30:41 video vdr: [3935] CAM 1: replies to QUERY - multi channel decryption possible
Jul 21 12:30:42 video vdr: [3939] CAM 3: doesn't reply to QUERY - only a single channel can be decrypted

Should be self-explanatory ;-)

Klaus



More information about the vdr mailing list