[vdr] blank screen with xv softdevice on NVIDIA 6150

VDR vdr at lucke.in-berlin.de
Thu Oct 25 14:03:50 CEST 2007


Quoting Fabian Ritzmann:

> On 10/24/07, vdr at lucke.in-berlin.de <vdr at lucke.in-berlin.de> wrote:
> > Quoting Fabian Ritzmann:
> >
> > > The issue I am seeing with softdevice is that I have a black screen
> > > that displays the OSD just fine. In other words, the TV broadcasts are
> > > not being displayed but I can see and use the VDR menus as well as
> > > teletext and DVB subtitles (pretty weird seeing the subtitles
> > > displayed v-a-v a black picture).
> >
> > You should set OSD alpha blending to "software" instead of "pseudo".
>
> Thanks, but unfortunately that has not helped. These are the settings
> I am using now:
>
> softdevice.AC3Mode = 0
> softdevice.AlsaAC3Device = hw:0,1
> softdevice.AlsaDevice = default
> softdevice.autodetectAspect = 0
> softdevice.avOffset = 0
> softdevice.bufferMode = 0
> softdevice.CropBottomLines = 0
> softdevice.CropLeftCols = 0
> softdevice.CropMode = 0
> softdevice.CropModeToggleKey = 0
> softdevice.CropRightCols = 0
> softdevice.CropTopLines = 0
> softdevice.Deinterlace Method = 0
> softdevice.ExpandLeftRightCols = 0
> softdevice.ExpandTopBottomLines = 0
> softdevice.mainMenu = 1
> softdevice.OSDalphablend = 1
> softdevice.Picture mirroring = 0
> softdevice.PixelAspect = 0
> softdevice.PixelFormat = 2
> softdevice.Postprocess Method = 0
> softdevice.Postprocess Quality = 0
> softdevice.Suspend = 0
> softdevice.syncTimerMode = 2
> softdevice.UseSetSourceRectangle = 0
> softdevice.UseStretchBlit = 0

> softdevice.vidBrightness = -1
> softdevice.vidContrast = -1
> softdevice.vidHue = -1
> softdevice.vidSaturation = -1

Are these controls (brightness,  etc.) available via OSD and changeable ?

> softdevice.Xv-Aspect = 1
>

Stefan



More information about the vdr mailing list