[vdr] VDR 1.7 - DVB Linux API problem

Lauri Tischler lwgt at iki.fi
Wed Aug 13 15:11:46 CEST 2008


David Hláčik wrote:
> Hello guys,
> 
> I have Fedora 9 with lastest kernel. I have Skystar 2 DVB PCI card rev 2.8.
> As this revision is using FlexCopII DVB i needed to recompile v4l dvb
> modules. I have downloaded lastest v4l using mercurial.
> Now my Skystar 2 works fine with Fedora 9 . I am using Kaffeine , which
> works fine.
> 
> My problem is :
> I am trying to compile vdr-1.7.0 from source, when i will do "make" i will
> get this error :
> 
> [root at home vdr-1.7.0]# make
> In file included from audio.c:12:
> dvbdevice.h:19:2: error: #error VDR requires Linux DVB driver API version
> 3.3!
> In file included from dvbdevice.c:10:
> dvbdevice.h:19:2: error: #error VDR requires Linux DVB driver API version
> 3.3!
> In file included from dvbosd.c:15:
> dvbdevice.h:19:2: error: #error VDR requires Linux DVB driver API version
> 3.3!
> In file included from eitscan.c:13:
> dvbdevice.h:19:2: error: #error VDR requires Linux DVB driver API version
> 3.3!
> font.c:14:10: error: #include expects "FILENAME" or <FILENAME>
> In file included from vdr.c:45:
> dvbdevice.h:19:2: error: #error VDR requires Linux DVB driver API version
> 3.3!
> make: *** Deleting file `.dependencies'
> g++ -g -O2 -Wall -Woverloaded-virtual -Wno-parentheses -c -DREMOTE_KBD
> -DLIRC_DEVICE=\"/dev/lircd\" -DRCU_DEVICE=\"/dev/ttyS1\" -D_GNU_SOURCE
> -DVIDEODIR=\"/video\" -DCONFDIR=\"/video\" -DPLUGINDIR=\"./PLUGINS/lib\"
> -DLOCDIR=\"./locale\" -I/usr/include/freetype2
> -I/usr/src/v4l-dvb/linux/include audio.c
> In file included from audio.c:12:
> dvbdevice.h:19:2: error: #error VDR requires Linux DVB driver API version
> 3.3!
> In file included from audio.c:12:
> dvbdevice.h:38: error: 'dvbfe_delsys' does not name a type
> make: *** [audio.o] Error 1
> 
> 
> As i mentioned before, i had to recompile v4l-dvb modules, location is
> /usr/src/v4l-dvb/.
> 
> I have edited Make.config and uncommented :
> ### The directory environment:
> DVBDIR   = /usr/src/v4l-dvb/linux
> 
> Which seems to me correct right?

Vanilla VDR-1.7.0 does not work with v4l-dvb drivers.
You have two options :
- download multiproto drivers from http://jusst.de/hg/multiproto
   make and make install
   you may need to patch those drivers, depends on your kernel version
- patch vdr-1.7.0 with dvb-api-patch, then it works with standard
   v4l-dvb drivers. http://www.udo-richter.de/vdr/patches.en.html#dvb-api-wrapper

if you need support for dvb-S2 then your only option is multiproto




More information about the vdr mailing list