[vdr] can't compile xine for vdr

Andreas Hölscher andreas at andreas-hoelscher.de
Mon Dec 22 17:56:47 CET 2008


Hi,
I installed a fresh SuSE 11.1 on my computer and tried to compile
xine-lib for use with xine vdr plugin. I patched xine-lib as described
in INSTALL in xine plugin and started ./autogen.sh.
make then gives me:

[..]
make[1]: Leaving directory `/opt/dvb/xine-lib/include'
Making all in lib
make[1]: Entering directory `/opt/dvb/xine-lib/lib'
/bin/sh ../libtool --tag=CC   --mode=link gcc  -D_REENTRANT
-D_FILE_OFFSET_BITS=64 -DXINE_COMPILE   -Wformat=2
-Wno-format-zero-length -Wmissing-format-attribute
-Werror-implicit-function-declaration -Wstrict-aliasing=2
-mtune=pentiumpro -O3 -pipe -fomit-frame-pointer -falign-functions=4
-falign-loops=4 -falign-jumps=4   -fexpensive-optimizations
-fschedule-insns2 -ffast-math -finline-functions -Wall -Wpointer-arith
-Wnested-externs -Wcast-align -Wchar-subscripts -Wmissing-declarations
-Wmissing-prototypes -g -O2 -DNDEBUG   -o libxineposix.la
../libtool: line 460: CDPATH: command not found
../libtool: line 1138: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2.6, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.6
libtool: and run autoconf again.
make[1]: *** [libxineposix.la] Error 63
make[1]: Leaving directory `/opt/dvb/xine-lib/lib'
make: *** [all-recursive] Error 1
[..]

I'm not a programmer, so I don't know what to do now. Can anyone point
me in the right direction please?

TIA,
Andreas

vdr: 1.6.0
xine: 0.8.2
xine-lib: xine-lib-cvs-20080310200000
xine-ui: xine-ui-cvs-20080310200000




More information about the vdr mailing list