[vdr] Installing a dvb-t card

Daniel Tahin td9678td at aim.com
Wed Dec 24 00:11:25 CET 2008


Hello,

i'm a newbie in dvb-t under Linux. Perhaps my problem is alredy solved, 
or discussed.
I would like to use a tv-card (Compro T750; it has an analog and dvb-t 
tuner) under Linux, because the software for windows has some annoying bug.
If i try to load the driver (modprobe  saa7134 i2c_scan=1), this appears 
after dmesg:

saa7130/34: v4l2 driver version 0.2.14 loaded
saa7133[0]: found at 0000:02:01.0, rev: 209, irq: 21, latency: 32, mmio: 
0xfb004000
saa7133[0]: subsystem: 185b:c900, board: UNKNOWN/GENERIC 
[card=0,autodetected]
saa7133[0]: board init: gpio is 94bf00
saa7133[0]: i2c eeprom 00: 5b 18 00 c9 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7133[0]: i2c eeprom 10: 00 ff 86 0f ff 20 ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 20: 01 40 01 03 03 01 03 01 08 ff 00 89 ff ff ff ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 40: ff d7 00 c4 86 1e 05 ff 02 c2 ff 01 ff ff ff ff
saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff cb
saa7133[0]: i2c eeprom 60: 30 ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 80: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 90: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom a0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom b0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom c0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom d0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom e0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom f0: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c scan: found device @ 0x1e  [???]
saa7133[0]: i2c scan: found device @ 0xa0  [eeprom]
saa7133[0]: i2c scan: found device @ 0xc2  [???]
saa7133[0]: i2c scan: found device @ 0xc4  [???]
saa7133[0]: i2c scan: found device @ 0xd0  [???]
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0


I'm not sure if i should install video4linux or linuxtv to recognize the 
card (or at least the dvb-t tuner on the card).
Linux is Fedora 9, kernel: 2.6.25-14.
And if i start VDR, i get this:
vdr: no primary device found - using first device
vdr version is 1.6.0.

Could someone help me please?

Thanx in advance,
Daniel




More information about the vdr mailing list