[vdr] [ANNOUNCE] vdr-xine-0.8.1 plugin

Gregoire Favre gregoire.favre at gmail.com
Wed Jan 2 21:41:07 CET 2008


On Wed, Jan 02, 2008 at 06:23:24PM +0100, Reinhard Nissl wrote:

> That's not correct. The check ensures that both ends of the
> connection are compatible.
> 
> Maybe it was no good idea to not mention in the announcement that
> this time xine-lib-1.1 needs to be patched or that you need to
> pull xine-lib-1.2 respectively.
> 
> In both ways you'll get a vdr.h (.../xine-lib-1.1/src/vdr/vdr.h
> or .../xine-lib-1.2/include/xine/vdr.h) which defines
> XINE_VDR_VERSION as 801 and therefore matches
> MIN_XINE_VDR_VERSION 801 in xineCommon.h. After building and
> installing xine-lib, you'll find vdr.h in both cases in
> .../include/xine/vdr.h.

Strange I only use xine-lib-1.2, I have the /usr/include/xine/vdr.h
which has the
XINE_VDR_VERSION as 801

But I still get the :

vdr-xine: Client reports unsupported version 712 => disconnecting!
vdr-xine: Client connect failed!

I think when I compil xine-lib, the vdr.h isn't included to put the
version in it somehow ???

I use this to compil xine-lib-1.2 :

#!/bin/bash
source /etc/make.conf
p=/data/linux/dvb/patches/xine/xine-lib.patch
MAKE='sudo nice -n 4 make -j3'
OPTIONS="show update dry-run apply undry-run  unapply compile log exit"
select opt in $OPTIONS; do
	if [ "$opt" = "show" ]; then
		vi $p
	elif [ "$opt" = "update" ]; then
		hg pull -u http://hg.debian.org/hg/xine-lib/xine-lib-1.2/
	elif [ "$opt" = "dry-run" ]; then
		patch --dry-run -p1 < $p
	elif [ "$opt" = "apply" ]; then
		patch -p1 < $p
	elif [ "$opt" = "undry-run" ]; then
		patch --dry-run -p1 -R < $p
	elif [ "$opt" = "unapply" ]; then
		patch -p1 -R < $p
	elif [ "$opt" = "compile" ]; then
		sudo ./autogen.sh --disable-dxr3 --enable-opengl --enable-v4l \
		--enable-glu --enable-dvb --prefix=/usr \
		--with-alsa --with-external-ffmpeg --with-fontconfig \
		--with-freetype --with-x --with-xv-path=/usr/X11R6/lib \
		--x-includes=/usr/include && $MAKE && $MAKE install && $MAKE distclean
	elif [ "$opt" = "log" ]; then
		hg log|less
	elif [ "$opt" = "exit" ]; then
		exit
	else
		echo bad option
	fi
done

-- 
Grégoire FAVRE  http://gregoire.favre.googlepages.com  http://www.gnupg.org
               http://picasaweb.google.com/Gregoire.Favre



More information about the vdr mailing list