[vdr] [ANNOUNCE] vdr-xine-0.8.1 plugin

Reinhard Nissl rnissl at gmx.de
Wed Jan 2 23:38:15 CET 2008


Hi,

Gregoire Favre schrieb:

> Strange I only use xine-lib-1.2, I have the /usr/include/xine/vdr.h
> which has the
> XINE_VDR_VERSION as 801
> 
> But I still get the :
> 
> vdr-xine: Client reports unsupported version 712 => disconnecting!
> vdr-xine: Client connect failed!
> 
> I think when I compil xine-lib, the vdr.h isn't included to put the
> version in it somehow ???
> 
> I use this to compil xine-lib-1.2 :

Hmm, I can only think of the following scenario:
- you've pulled before me pushing version number
- compiled
- installed
- you've pulled again, this time after pushing the version number
- compiled, using the previously installed vdr.h
- installed
- wonder why it doesn't work, as you have the correct vdr.h

Try uninstalling xine-lib-1.2 first, build and install again. I
hope it works then.

If it works, file a bug report in xine's bug tracker regarding
the build system. But I'm not sure whether it is correct to build
a software which is still installed on the system in a previous
version.

Bye.
-- 
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl at gmx.de



More information about the vdr mailing list