[vdr] CAM problems

Tomas Sävenstedt tomas at ladata.se
Mon Jan 7 16:31:22 CET 2008


Hello,

I´m running VDR 1.4.3 successfully on my Techotrend FF DVB-T with CI adapter
(Sweden).

Was interested in the new Subtitles + ttxtsubs so I have started to test the
new version.
The problem is that the CAM (Viaccess 8.84) is only working for some
channels.
In the user.log below channels 1,2 and 4 are free. The rest not.
Channel 3 and 9 tune in but not 5 (absolutely nothing happens).
I am running the same channels.conf as for 1.4.3
and the channels are spread over different transponders.
Also I don´t get the message 'Insert you card' when I take it out.

Opening the CAM from setup works OK!

Is there a way to debug what is happening?

Jan  4 19:59:44 LA1 vdr: [15679] VDR version 1.5.12 started
Jan  4 19:59:44 LA1 vdr: [15679] running as daemon (tid=15679)
Jan  4 19:59:44 LA1 vdr: [15679] codeset is 'UTF-8' - known
Jan  4 19:59:44 LA1 vdr: [15679] found 22 locales in
/usr/local/share/vdr/locale
Jan  4 19:59:44 LA1 vdr: [15679] loading plugin:
/usr/local/lib/vdr/libvdr-ttxtsubs.so.1.5.12
Jan  4 19:59:44 LA1 vdr: [15679] loading /home/kets/.vdr/setup.conf
Jan  4 19:59:44 LA1 vdr: [15679] loading /home/kets/.vdr/sources.conf
Jan  4 19:59:44 LA1 vdr: [15679] loading /home/kets/.vdr/channels.conf
Jan  4 19:59:44 LA1 vdr: [15679] loading /home/kets/.vdr/timers.conf
Jan  4 19:59:44 LA1 vdr: [15679] loading /home/kets/.vdr/svdrphosts.conf
Jan  4 19:59:44 LA1 vdr: [15679] loading /home/kets/.vdr/remote.conf
Jan  4 19:59:44 LA1 vdr: [15679] loading /home/kets/.vdr/keymacros.conf
Jan  4 19:59:44 LA1 vdr: [15679] reading EPG data from /video0/epg.data
Jan  4 19:59:44 LA1 vdr: [15681] video directory scanner thread started
(pid=15679, tid=15681)
Jan  4 19:59:44 LA1 vdr: [15682] video directory scanner thread started
(pid=15679, tid=15682)
Jan  4 19:59:44 LA1 vdr: [15679] probing /dev/dvb/adapter0/frontend0
Jan  4 19:59:44 LA1 vdr: [15684] CI adapter on device 0 thread started
(pid=15679, tid=15684)
Jan  4 19:59:45 LA1 vdr: [15679] found 1 video device
Jan  4 19:59:45 LA1 vdr: [15679] initializing plugin: ttxtsubs (0.0.5-RRE):
Teletext subtitles
Jan  4 19:59:45 LA1 vdr: [15679] setting primary device to 1
Jan  4 19:59:45 LA1 vdr: [15688] tuner on device 1 thread started
(pid=15679, tid=15688)
Jan  4 19:59:45 LA1 vdr: [15689] section handler thread started (pid=15679,
tid=15689)
Jan  4 19:59:45 LA1 vdr: [15679] assuming manual start of VDR
Jan  4 19:59:45 LA1 vdr: [15679] SVDRP listening on port 2001
Jan  4 19:59:45 LA1 vdr: [15679] setting current skin to "sttng"
Jan  4 19:59:45 LA1 vdr: [15679] loading
/home/kets/.vdr/themes/sttng-default.theme
Jan  4 19:59:45 LA1 vdr: [15679] starting plugin: ttxtsubs
Jan  4 19:59:45 LA1 vdr: [15679] remote control LIRC - keys known
Jan  4 19:59:45 LA1 vdr: [15691] LIRC remote control thread started
(pid=15679, tid=15691)
Jan  4 19:59:45 LA1 vdr: [15684] CAM 2: module present
Jan  4 19:59:45 LA1 vdr: [15681] video directory scanner thread ended
(pid=15679, tid=15681)
Jan  4 19:59:45 LA1 vdr: [15682] video directory scanner thread ended
(pid=15679, tid=15682)
Jan  4 19:59:46 LA1 vdr: [15684] CAM 1: no module present
Jan  4 19:59:47 LA1 vdr: [15684] CAM 2: no module present
Jan  4 19:59:47 LA1 vdr: [15679] switching to channel 1
Jan  4 19:59:47 LA1 vdr: [15684] CAM 2: module present
Jan  4 19:59:49 LA1 vdr: [15684] CAM 2: no module present
Jan  4 19:59:49 LA1 vdr: [15684] CAM 2: module present
Jan  4 19:59:51 LA1 vdr: [15684] CAM 2: module ready
Jan  4 19:59:54 LA1 vdr: [15684] CAM 2: Viaccess, 01, 0500, 0500
Jan  4 19:59:58 LA1 vdr: [15684] CAM 2: doesn't reply to QUERY - only a
single channel can be decrypted
Jan  4 20:59:45 LA1 vdr: [15679] cleaning up schedules data
Jan  4 21:00:58 LA1 vdr: [15679] switching to channel 3
Jan  4 21:00:58 LA1 vdr: [15679] CAM 2: assigned to device 1
Jan  4 21:00:58 LA1 vdr: [15750] transfer thread started (pid=15679,
tid=15750)
Jan  4 21:00:58 LA1 vdr: [15751] receiver on device 1 thread started
(pid=15679, tid=15751)
Jan  4 21:00:58 LA1 vdr: [15752] TS buffer on device 1 thread started
(pid=15679, tid=15752)
Jan  4 21:01:04 LA1 vdr: [15679] CAM 2: unassigned
Jan  4 21:01:04 LA1 vdr: [15679] switching to channel 4
Jan  4 21:01:04 LA1 vdr: [15679] buffer stats: 41736 (1%) used
Jan  4 21:01:05 LA1 vdr: [15755] TS buffer on device 1 thread ended
(pid=15679, tid=15755)
Jan  4 21:01:05 LA1 vdr: [15754] buffer stats: 41360 (1%) used
Jan  4 21:01:05 LA1 vdr: [15754] receiver on device 1 thread ended
(pid=15679, tid=15754)
Jan  4 21:01:31 LA1 vdr: [15679] switching to channel 5
Jan  4 21:01:50 LA1 vdr: [15679] switching to channel 9
Jan  4 21:01:50 LA1 vdr: [15679] CAM 2: assigned to device 1
Jan  4 21:01:50 LA1 vdr: [15756] transfer thread started (pid=15679,
tid=15756)
Jan  4 21:01:50 LA1 vdr: [15757] receiver on device 1 thread started
(pid=15679, tid=15757)
Jan  4 21:01:50 LA1 vdr: [15758] TS buffer on device 1 thread started
(pid=15679, tid=15758)

It would also be nice if ttxtsubs was included along with other subtitles.
(The patches are working perfectly even if not the CAM works,
but it would be nice with picture along with the subtitles).

Tomas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxtv.org/pipermail/vdr/attachments/20080107/731968b7/attachment.htm 


More information about the vdr mailing list