[vdr] new drivers

Hans Gustafsson hans.gustafsson at gmail.com
Thu Jan 17 23:32:25 CET 2008


On Jan 17, 2008 7:06 PM, Tony Grant <tony at tgds.net> wrote:
>
> > What video output driver do you use with xine?
>
> xxmc on VIA Epia M10000
>
> > Does the behavior change when using for example -V xshm?
>
> Yes!!!! You win!!!!
>
> 100% CPU but it changes channels.
>
> Back to Xavier and openchrome now?

Hi,

I have the same problem with xine sometimes showing just a blue screen
after a channel change and have the following output from xine when it
is started with --verbose=9.

snip
Duplicated XvMC frame 720 576.
0 1;1 1;0 0;0 0;
1 1;1 1;0 0;0 0;
video_out_xxmc: Disposing of subpicture 1
1 1;0 1;0 0;0 0;
vdr: osdflush: n: 1, 9.7, timeout: 0, result: 0
Duplicated XvMC frame 720 576.
1 1;0 1;0 0;0 0;
1 1;1 1;0 0;0 0;
video_out_xxmc: Disposing of subpicture 0
0 1;1 1;0 0;0 0;
vdr: osdflush: n: 1, 9.7, timeout: 0, result: 0
set_speed 125000
audio discontinuity #11, type is 2, disc_off 2452596738
waiting for in_discontinuity update #11
video discontinuity #11, type is 2, disc_off 2452596738
vpts adjusted with prebuffer to 3737993
libmpeg2: output port has XxMC capability
video_out_xxmc: VO_PROP_INTERLACED(0)
load_plugins: plugin mpeg2 will be used for video streamtype 00.
video_out_xxmc: VO_PROP_INTERLACED(1)
video_out_xxmc: New format. Need to change XvMC Context.
width: 544 height: 576 mpeg: 2 acceleration: 7
video_out_xxmc: Disposing of surface 3
1 1;1 1;1 1;0 1;1 1;1 1;1 1;1 1;1 1;1 1;1 1;1 1;1 1;1 1;1 1;0 0;
video_out_xxmc: Freeing up XvMC Surfaces and subpictures.
video_out_xxmc: Freeing up XvMC Context.
video_out_xxmc: Surface type 0. Capabilities 0x       2 0x       4
video_out_xxmc:   Requests: 0x       2 0x       4
video_out_xxmc: Creating new XvMC Context 842094169
load_plugins: plugin mad will be used for audio streamtype 01.
audio_alsa_out:open pause_resume=0
output sample rate 48000
audio jump, diff=10387
set_speed 1000000
fixing sound card drift by 2520 pts
set_speed 125000
set_speed 1000000

Now the picture goes blue and xine is not responding any more. If I
try to change channel, vdr will not respond and the watchdog timer
will expire resulting in a vdr restart.
Can the problem be that the width is set to 544?

I am running fedora 8 on an EPIA CN10000 with openchrome from
2007-12-27 and vdr-xine-0.8.1.

Thanks,
Hans



More information about the vdr mailing list