[vdr] vdr-iptv-0.0.5 + vdr-xine audio problem

Jouni Karvo Jouni.Karvo at iki.fi
Sat Jan 19 18:48:20 CET 2008


Segers,Jan J.K.T. kirjoitti:
> have a look here:
> http://www.global-itv.com/

thanks.  I found a couple of channels.

It seems that vlc is able to play the stream correctly, with both audio 
and video by itself.  But when I try to use it together with iptv 
plugin, it seems that for some reason audio is lost.

I use vdr-xine for output.

Xine output seems like it gets the audio, but it does not get any 
synchronization info correctly, as it just reports skipping audio:

excerpt from the xine logging:

plugin mad will be used for audio streamtype 01.
audio_alsa_out:open pause_resume=1
output sample rate 48000
audio jump, diff=-2160
set_speed 1000000
ao_flush (loop running: 1)
video discontinuity #25, type is 0, disc_off 0
waiting for audio discontinuity #25
ao_close
audio_out: no streams left, closing driver
audio discontinuity #25, type is 0, disc_off 0
waiting for in_discontinuity update #25
vpts adjusted with prebuffer to 3418578
ao_flush (loop running: 1)
video discontinuity #26, type is 0, disc_off 0
waiting for audio discontinuity #26
audio discontinuity #26, type is 0, disc_off 0
waiting for in_discontinuity update #26
vpts adjusted with prebuffer to 3418610


This is the corresponding stream entry for channels.conf:

Bahn TV;IPTV:3:IPTV|EXT|iptvstream.sh|3:P:0:4+3:5:0:0:1:0:0:0

What should I try?

yours,
		Jouni




More information about the vdr mailing list