[vdr] cTS2PES got 2 TS errors, 2 TS continuity errors - Channel Not Available????

Klaus Schmidinger Klaus.Schmidinger at cadsoft.de
Sun Jan 27 12:07:45 CET 2008


On 01/27/08 08:11, Simon Baxter wrote:
> Hi
> 
> I'm running vdr-1.5.12 with a TT-1500-C card, CI and alphacrypt multi-cam. 
> All channels are encrypted.
> 
> Intermittantly I try and switch to a channel and I get a "Channel not 
> available" message.  After switching back and forth between channels, 
> finally the channel will select, and everything's ok.
> 
> I've been trying to diagnose it, and so far all I can see is below:
> Jan 27 20:05:29 callin vdr: [3287] switching to channel 20
> Jan 27 20:05:29 callin vdr: [3287] cTS2PES got 2 TS errors, 2 TS continuity 
> errors
> Jan 27 20:05:29 callin vdr: [3287] buffer stats: 58656 (2%) used
> Jan 27 20:05:29 callin vdr: [3287] info: Channel not available!
> Jan 27 20:05:29 callin vdr: [4167] TS buffer on device 1 thread ended 
> (pid=3287, tid=4167)
> Jan 27 20:05:29 callin vdr: [4166] buffer stats: 58280 (2%) used
> Jan 27 20:05:29 callin vdr: [4166] receiver on device 1 thread ended 
> (pid=3287, tid=4166)
> 
> Can anyone tell me what this cTS2PES error is, and if it's likely to be to 
> do with my problem?  What else can I try?

Maybe your CAM needs longer than TS_SCRAMBLING_TIMEOUT (default is 3 seconds)
to start decrypting. You can try increasing that number in device.c.

It is also very likely that I am going to remove the two lines

       && !cDevice::SwitchChannel(1) // ...or the next higher available one...
       && !cDevice::SwitchChannel(-1)) // ...or the next lower available one

from vdr.c, in order to allow switching to a channel where the CAM needs
quite a long time, for instance to collect new keys because it hasn't
been tuned to an encrypted channel for a while.

Klaus



More information about the vdr mailing list