[vdr] xineliboutput with xxmc: slow OSD

Ondrej Wisniewski ondrej.wisniewski at ericsson.com
Tue Jan 29 09:01:26 CET 2008


Tony Grant wrote:
> Le lundi 28 janvier 2008 à 12:07 +0100, Ondrej Wisniewski a écrit :
> 
> Sorry I forgot to say I am using Fedora Core 8. There is an issue with
> libxcb and threads - it is fixed in OpenSuze10.3 says Reinhard.
> 
> With the OSD I have increase in CPU load and, in the terminal I am
> running Xine from, warning that I don't have enough colors etc. Can't
> zap from horizontal to vertical polarization.
> 
> Screen goes blue and VDR restarts
> 
> I am currently using the multiproto driver linked from the 1.5.14
> announcement.

I am using Ubuntu 7.10 with xine lib from the repos. Here's the problem 
I encounter. Might be the same bug you are talking about:

VDR is running with xineliboutput plugin. Remote frontend sxfe is 
started on the same PC:
$ vdr-sxfe --video=xxmc xvdr://127.0.0.1

Initially I get video and audio just fine with HW decoding. But when I 
switch channel and the OSD is shown I get lots of these:
video_out: Warning! Out of xx44 palette colors!

And shortly after the crash:
video_out_xxmc: Using software decoding for this stream.
libmpeg2: output port has XxMC capability
AFD changed from -2 to -1
video_out_xxmc: Using software decoding for this stream.
video_out_xxmc: Using hardware decoding for this stream.
*** glibc detected *** vdr-sxfe: double free or corruption (!prev): 
0x086d6558 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6[0xb7c72d65]
/lib/tls/i686/cmov/libc.so.6(cfree+0x90)[0xb7c76800]
/usr/lib/xine/plugins/1.1.8/xineplug_vo_out_xxmc.so[0xb6656685]

Looks like a xine problem, specifically the xxmc plugin.  :-(

Ondrej ...



More information about the vdr mailing list