[vdr] Problem with dvd plugin.. Anyone know how to fix?

VDR User user.vdr at gmail.com
Sun Jun 1 18:30:46 CEST 2008


On Sat, May 31, 2008 at 10:00 PM, Simon Baxter <linuxtv at nzbaxters.com> wrote:
> Hi.  I had the same problem originally.  Can't remember what I did, and in
> what order - but this should help....
>
> [root at callin dvd]# pwd
> /root/vdr-1.6.0/PLUGINS/src/dvd
> [root at callin dvd]# grep stdint.h *
> ca52.c:#include <stdint.h>
> tools-dvd.h:#include <stdint.h>
> [root at callin dvd]# grep inttypes.h *
> ca52.h:#include <inttypes.h>
> dvdspu.c:#include <inttypes.h>
> dvdspu.h:#include <inttypes.h>
> tools-dvd.h:#include <inttypes.h>

I added #include <stdint.h> and #include <inttypes.h> to the top of
all those files and still got the same error.  Which libdvdread-dev
version are you using?  I've got:
ii  libdvdread-dev               0.9.7-10                     library
for reading DVDs (development)

Btw, I also tried adding -D__STDC_LIMIT_MACROS to compiler parameters
as Anssi suggested but that had no affect as well.



More information about the vdr mailing list