[vdr] vdr-xine + mplayer-plugin + MPlayer - is it possible ?

Patrick Boettcher patrick.boettcher at desy.de
Tue Jun 10 20:31:11 CEST 2008


I don't know if this is applicable for your setup, but did you try 
vdr-plugin-xineliboutput instead of vdr-plugin-xine?

It is at least 3 things in one:

- Client/Server architecture: splits VDR (server) and displaying software
- Media Player integrated (via OSD)
- X11 (XV or others) display (vdr-sxfe)

Patrick.

On Tue, 10 Jun 2008, Goga777 wrote:

> Hi
>
> i try to run MPlayer on my vdr 170 + mplayer-plugin from HG + vdr-xine  (if it possible)
>
> in mplayer.sh I have written
>
> #!/bin/sh
> CMDLINE="mplayer -fs -vo xv -ao alsa -cache 4096 -slave -nolirc -quiet"
> DISPLAY=:0.0 $CMDLINE "$1" |logger
> exit
>
>
> but after the start of reply some file with mplayer-plugin I have
>
> resume: resume file is '/mnt/asp/video/hdtv/.mplayer.resume'
> resume: assuming empty resume file
> [VO_XV] Could not grab port 65.
> [VO_XV] Could not find free Xvideo port - maybe another process is already
> [VO_XV] using it. Close all video applications, and try again. If that does
> [VO_XV] not help, see 'mplayer -vo help' for other (non-xv) video out drivers.
> Error opening/initializing the selected video_out (-vo) device.
>
>
> Jun 8 01:54:53 localhost logger: MPEG-PES file format detected.
> Jun 8 01:54:53 localhost logger: ==========================================================================
> Jun 8 01:54:53 localhost logger: Opening audio decoder: [liba52] AC3 decoding with liba52
> Jun 8 01:54:53 localhost logger: AUDIO: 48000 Hz, 2 ch, s16le, 448.0 kbit/29.17% (ratio: 56000->192000)
> Jun 8 01:54:53 localhost logger: Selected audio codec: [a52] afm: liba52 (AC3-liba52)
> Jun 8 01:54:53 localhost logger: ==========================================================================
> Jun 8 01:54:53 localhost logger: AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
> Jun 8 01:54:53 localhost logger: Video: no video
> Jun 8 01:54:53 localhost logger: Starting playback...
> Jun 8 01:54:59 localhost kernel: dvb_frontend_ioctl: FESTATE_RETUNE: fepriv->state=2
> Jun 8 01:55:03 localhost logger:
> Jun 8 01:55:03 localhost logger:
> Jun 8 01:55:03 localhost logger: Exiting... (End of file)
> Jun 8 01:55:04 localhost vdr: [11413] mplayer: player thread ended (pid=11233)
> Jun 8 01:55:08 localhost vdr: [11420] mplayer: mplayer child started (pid=11420)
> Jun 8 01:55:08 localhost vdr: [11423] mplayer: player thread started (pid=11233)
> Jun 8 01:55:08 localhost logger: MPlayer dev-SVN-r26871-4.2.4 (C) 2000-2008 MPlayer Team
> Jun 8 01:55:08 localhost logger: CPU: Intel(R) Pentium(R) 4 CPU 3.00GHz (Family: 15, Model: 3, Stepping: 4)
> Jun 8 01:55:08 localhost logger: CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
> Jun 8 01:55:08 localhost logger: Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
> Jun 8 01:55:08 localhost logger:
> Jun 8 01:55:08 localhost logger: Playing /mnt/asp/video/hdtv/1muz.ts.
> Jun 8 01:55:08 localhost logger:
> Jun 8 01:55:08 localhost logger: TS file format detected.
> Jun 8 01:55:08 localhost logger: VIDEO H264(pid=53 AUDIO MPA(pid=725) NO SUBS (yet)! PROGRAM N. 18
> Jun 8 01:55:08 localhost logger: FPS seems to be: 25.000000
> Jun 8 01:55:08 localhost logger: ==========================================================================
> Jun 8 01:55:08 localhost logger: Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
> Jun 8 01:55:08 localhost logger: AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
> Jun 8 01:55:08 localhost logger: Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
> Jun 8 01:55:08 localhost logger: ==========================================================================
> Jun 8 01:55:08 localhost logger: AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
> Jun 8 01:55:08 localhost logger: Video: no video
> Jun 8 01:55:08 localhost logger: Starting playback...
> Jun 8 01:55:10 localhost kernel: dvb_frontend_ioctl: FESTATE_RETUNE: fepriv->state=2
> Jun 8 01:55:20 localhost vdr: [11237] frontend 0 timed out while tuning to channel 2782, tp 111055
> Jun 8 01:55:20 localhost kernel: dvb_frontend_ioctl: FESTATE_RETUNE: fepriv->state=2
> Jun 8 01:55:26 localhost logger: TS_PARSE: COULDN'T SYNC
> Jun 8 01:55:26 localhost logger:
> Jun 8 01:55:26 localhost logger:
> Jun 8 01:55:26 localhost logger: Exiting... (End of file)
> Jun 8 01:55:27 localhost vdr: [11423] mplayer: player thread ended (pid=11233)
>
>
> I think the xine locked the videocard and due to this MPlayer can't lock it.
> Is it possible to solve this issue ?
>
> Goga777
>
>
>
>
> _______________________________________________
> vdr mailing list
> vdr at linuxtv.org
> http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr
>



More information about the vdr mailing list